Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#4383 closed defect (fixed)

IE not respecting Easylist

Reported by: ytadesse Assignee: oleksandr
Priority: P2 Milestone: Adblock-Plus-for-Internet-Explorer-1.6
Module: Adblock-Plus-for-Internet-Explorer Keywords:
Cc: sergz, oleksandr, arthur, greiner Blocked By:
Blocking: Platform: Internet Explorer
Ready: yes Confidential: no
Tester: Rraceanu Verified working: yes
Review URL(s):

Description

Environment

OS: Windows 10
Browser: IE v11.545.10586.0
ABP Version: 1.5
Enabled Filter Lists: Just Easylist (the default)

--

Also worth noting that this has been reproduced across various Windows OSs & IE versions (although, not on IE 11.0.9600.18376 on Windows 7 Premium).

How to reproduce

  1. Using IE, install ABP using the large install button on https://adblockplus.org
  2. After installation is complete, close IE to ensure it's installed and then re-open it
  3. Verify that the ABP logo is at the bottom right is red to ensure it's operating
  4. Visit various sites listed on the EasyList (https://easylist-downloads.adblockplus.org/exceptionrules.txt), such as verywell.com, search.ask.com, and search.myway.com and run a search for "Flower Shop"

...

Observed behaviour

No AFS ads are displayed at the top of the search results page.

Expected behaviour

AFS ads are displayed at the top of the search results page.

Change History (16)

comment:1 Changed 3 years ago by ytadesse

Hello, just checking to see if there are any updates here. Thank you.

comment:2 Changed 3 years ago by arthur

  • Cc sergz oleksandr arthur added

comment:3 Changed 3 years ago by greiner

  • Cc greiner added

EasyList is only blocking ads whereas exceptionrules.txt (the list used for Acceptable Ads) is unblocking ads and is only active if the checkbox next to "Enable some non-intrusive advertising" is checked in the options page. Can you check whether this setting is enabled?

Note that by default it should be enabled when you install the extension.

comment:4 Changed 3 years ago by ytadesse

Thanks for getting back to me on this. Apologies for the confusion (re: EasyList/exceptionrules) - I'm certainly referring to the Acceptable Ads exception rule list. And, yes, I verified that the setting is checked.

Last edited 3 years ago by ytadesse (previous) (diff)

comment:5 Changed 3 years ago by oleksandr

  • Component changed from Unknown to Adblock-Plus-for-Internet-Explorer
  • Owner set to oleksandr
  • Priority changed from Unknown to P2

comment:6 Changed 3 years ago by oleksandr

The core of this issue seems to be the same as #1642. Both of these are fixed by #119, which is currently being internally tested.

comment:7 Changed 3 years ago by ytadesse

Great! Thank you for that update. And, lastly, what would be an estimated go-live time-period for this change (days, weeks, months)?

comment:8 Changed 3 years ago by oleksandr

The devbuild will probably go live next week. The general availability depends on how it behaves with our users, but usually we release in about 2-3 weeks after a devbuild.

comment:9 Changed 3 years ago by ytadesse

Gotcha, and, just so I know - with what level of certainty can you say that this is indeed the same core issue as #1642?

comment:10 Changed 3 years ago by oleksandr

I am unable to reproduce this on our internal build. So even if it were a different issue I am fairly certain it is fixed now.

comment:11 Changed 3 years ago by ytadesse

Excellent. Thank you for all the updates today :)

comment:12 Changed 3 years ago by ytadesse

Hello! Hoping you could provide an update on this. Is this still on track for an an end-of-month(ish) launch?

comment:13 Changed 3 years ago by oleksandr

Unfortunately there will be a few days of delay since we have found #4486 during our testing.

comment:14 Changed 3 years ago by oleksandr

  • Milestone set to Adblock-Plus-for-Internet-Explorer-Next
  • Ready set

This should be fixed in the latest devbuild 1.5.855

comment:15 Changed 3 years ago by oleksandr

  • Resolution set to fixed
  • Status changed from new to closed

comment:16 Changed 3 years ago by rraceanu

  • Tester changed from Unknown to Rraceanu
  • Verified working set

Change successfully implemented, AFS ads are shown during search queries (verified on: Ask.com, Google.com, verywell.com, search.myway.com, netzwelt.de) on IE 10 Windows 8, IE 11 Windows 10, ABP version 1.5.856

Note: See TracTickets for help on using tickets.