Opened 3 years ago

Closed 3 years ago

#4392 closed defect (rejected)

Background image on interest.co.nz cannot be blocked in Safari

Reported by: arthur Assignee:
Priority: Unknown Milestone:
Module: Platform Keywords:
Cc: sebastian, kzar Blocked By:
Blocking: Platform: Safari
Ready: no Confidential: no
Tester: Unknown Verified working: no
Review URL(s):

Description

Environment

OS X El Captian 10.11.3
Safari 9.0.3
ABP 1.12.2
EasyList

How to reproduce

  1. Add this custom filter to ABP: ||interest.co.nz/sites/default/files/skins/
  2. Go to http://www.interest.co.nz/

Observed behaviour

The background image isn't blocked.

Expected behaviour

The back ground image should be blocked.

Change History (2)

comment:1 Changed 3 years ago by mapx

in 2014, Sebastian wrote:

Apparently you try to block a background image. Unfortunately we can not block images loaded via CSS on Safari. This is a limitation of Safari's extension API.

https://adblockplus.org/forum/viewtopic.php?p=99533#p99533

since then was the safari's extension api improved ?

comment:2 Changed 3 years ago by kzar

  • Component changed from Unknown to Platform
  • Resolution set to rejected
  • Status changed from new to closed

Unfortunately I can only recommend using Chrome or Firefox instead, sorry.

Note: See TracTickets for help on using tickets.