Opened 6 months ago

Closed 6 months ago

Last modified 4 months ago

#4398 closed defect (fixed)

Element Hiding Helper U view source (in separate window) broken in Firefox 48

Reported by: DrainElephant Assignee: trev
Priority: P1 Milestone: Element-Hiding-Helper-1.3.10
Module: Extensions-for-Adblock-Plus Keywords: elemhidehelper
Cc: trev, mapx Blocked By:
Blocking: Platform: Firefox
Ready: yes Confidential: no
Tester: Ross Verified working: yes
Review URL(s):

https://codereview.adblockplus.org/29352667/

Description

Environment

Ubuntu 16.04 LTS,
Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:48.0) Gecko/20100101 Firefox/48.0,
Adblock Plus 2.7.3
Element Hiding Helper 1.3.9

How to reproduce

Adblock Plus -- Select element to hide -- U [keypress]

Observed behaviour

A blank window opens. No source code visible.

Expected behaviour

Source code visible.

Additional info

This worked until recently, possibly with a previous version of Firefox or Adblock Plus/Element Hiding Helper. I think Firefox may have changed how they deal with Tools -- Web Developer -- Page Source, which may be related. Either way, the above breakage occurs with Element Hiding Helper.

I did search for a pre-existing bug on this, and having found none am submitting this new one.

Change History (9)

comment:1 Changed 6 months ago by mapx

  • Cc trev greiner mapx added
  • Component changed from Unknown to Adblock-Plus-for-Firefox

comment:2 Changed 6 months ago by mapx

in console:

TypeError: args is null
onLoadViewPartialSource()
viewPartialSource.js:20
onload()
viewPartialSource.xul:1

comment:3 Changed 6 months ago by trev

  • Cc greiner removed
  • Component changed from Adblock-Plus-for-Firefox to Extensions-for-Adblock-Plus
  • Keywords elemhidehelper added
  • Owner set to trev
  • Priority changed from Unknown to P1
  • Ready set

comment:4 Changed 6 months ago by trev

  • Review URL(s) modified (diff)
  • Status changed from new to reviewing

comment:5 Changed 6 months ago by abpbot

A commit referencing this issue has landed:
Issue 4398 - Fix "view source in a separate window" command

comment:6 Changed 6 months ago by trev

  • Milestone set to Element-Hiding-Helper-next
  • Resolution set to fixed
  • Status changed from reviewing to closed

comment:7 Changed 4 months ago by Ross

  • Tester changed from Unknown to Ross
  • Verified working set

Fixed.

Firefox 38 / 48 / Nightly 52.0a1 (2016-10-23)
Firefox 45 / Ubuntu 14.04

comment:8 Changed 4 months ago by DrainElephant

Thanks for fixing the reported issue. I too can confirm that it works.

I have however noticed something else that may or may not be related, and that may or may not be an actual issue and change vis-à-vis the previous behaviour:

When I go: Adblock Plus -- Select element to hide -- V [keypress] (that's V, not U this time), then only the structural tags are displayed, not the other selected content that would go in those tags. I am not sure if the absence of this source content is by design or if it used to be displayed in previous versions. I have not tested previous versions. I just thought I'd add this information, in case this is an issue. If it is an issue, then I'm not sure if that would call for a new ticket or not.

comment:9 Changed 4 months ago by trev

No, this is not related but it is indeed a regression - a very old one. It seems that you were the first one to report this after almost five years. I filed https://issues.adblockplus.org/ticket/4588 on it.

Note: See TracTickets for help on using tickets.