Opened 3 years ago

Closed 3 months ago

#4405 closed defect (rejected)

Hiding filters doesn't work on fs.to

Reported by: Lain_13 Assignee:
Priority: Unknown Milestone:
Module: Platform Keywords: circumvention, closed-in-favor-of-gitlab
Cc: mapx, kzar, sebastian, amrmak Blocked By:
Blocking: Platform: Chrome
Ready: no Confidential: no
Tester: Unknown Verified working: no
Review URL(s):

Description (last modified by kzar)

Environment

Google Chrome Version 53.0.2785.89 m
Adblock Plus development build 1.12.2.1649

How to reproduce

  1. Add filter: fs.to##div[id^="adsProxy-"]
  2. Add RuAdList+EasyList filter list.
  3. Visit http://fs.to (brb.to, cxz.to)

Observed behaviour

Ad in the middle of the page with id="adsProxy-zone-section-glowadswide" is displayed.

Expected behaviour

Ad is not displayed.

Additional information

I've noticed they removing all elements on the page and re-attaching them for some reason. This could be the root cause. Also, behavior of the page in #4390 is similar.

Change History (10)

comment:1 Changed 3 years ago by Lain_13

Eww, I forgot about ^ once again. Please fix it.

comment:2 Changed 3 years ago by mapx

  • Cc mapx added
  • Description modified (diff)

comment:3 Changed 3 years ago by mapx

  • Component changed from Unknown to Platform
  • Platform changed from Unknown / Cross platform to Chrome

comment:4 Changed 3 years ago by mapx

  • Cc kzar sebastian added

comment:5 Changed 3 years ago by kzar

  • Description modified (diff)

I wasn't able to reproduce this, are you still having this problem?

comment:6 Changed 3 years ago by Lain_13

I still having this problem. Try here: http://fs.to/video/serials/
Besides weird manipulations with document.body I've noticed they generate 2-3 more shadow-roots. When there are 4 all styles end up broken and when there are 3 all ads displayed.

comment:7 Changed 3 years ago by Lain_13

BTW, recently their code went berserk and now may trigger and break page even when ABP, Stylish and Tampermonkey are all disabled.

comment:8 Changed 21 months ago by mjethani

  • Keywords circumvention added

comment:9 Changed 21 months ago by amrmak

  • Cc amrmak added

comment:10 Changed 3 months ago by sebastian

  • Keywords closed-in-favor-of-gitlab added
  • Resolution set to rejected
  • Status changed from new to closed

Sorry, but we switched to GitLab. If this issue is still relevant, please file it again in the new issue tracker.

Note: See TracTickets for help on using tickets.