Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#442 closed defect (rejected)

ABP 1.8 wrong number of hits on youtube

Reported by: mapx Assignee:
Priority: P1 Milestone:
Module: Platform Keywords:
Cc: sebastian, trev Blocked By:
Blocking: Platform:
Ready: no Confidential: no
Tester: Verified working: no
Review URL(s):

Description (last modified by mapx)

chrome 34, 36 ...
Adblock Plus development build 1.8.0.1180

go to https://www.youtube.com/watch?v=_-HWHLObocg

the number in icon will indicate 27
click on some other video in the suggestions list (on the right) ==> the counting will continue from 27 ! (the counter is not initialized)

reported here:
https://adblockplus.org/forum/viewtopic.php?f=10&t=23003

Change History (8)

comment:1 Changed 5 years ago by mapx

  • Description modified (diff)

comment:2 Changed 5 years ago by mapx

  • Description modified (diff)

comment:3 Changed 5 years ago by sebastian

The ad counter is only reset when navigating to a different page or reloading the current page. However when you click on another video on YouTube, no navigation occurs. Instead YouTube updates the content of the web page with JavaScript and updates the URL using the history API. IMO not resetting the ad counter in that cases should be the intended behavior.

comment:4 Changed 5 years ago by mapx

right, on facebook it's the same behaviour.
However, the information is not correct: on that page, in that moment there are 27 ads and not 54, ...

Last edited 5 years ago by mapx (previous) (diff)

comment:5 Changed 5 years ago by trev

  • Resolution set to rejected
  • Status changed from new to closed

comment:6 Changed 5 years ago by mapx

well, for me is a wrong behaviour ==> the user needs the real time numbers of the ads and not the summed amount of ads (if someone keeps a tab for few days he will thousand of ads on YT or FB)

Version 0, edited 5 years ago by mapx (next)

comment:7 Changed 5 years ago by sebastian

Technically it it still the same page. Though it might be irritating, on websites like Facebook and YouTube, that appear to load another web page when you click a link, while the entire website is actually a single page. But there is no way to distinguish that from web pages that update the URL while showing the same content, for example in response to form input or scrolling.

comment:8 Changed 5 years ago by mapx

got it (if technically there is no way)

Note: See TracTickets for help on using tickets.