Opened 5 years ago

Closed 5 years ago

#444 closed defect (worksforme)

ABP for Android don't block ads on Some Websites

Reported by: saroyanm Assignee:
Priority: Unknown Milestone:
Module: Adblock-Plus-for-Android Keywords:
Cc: philll, fhd, arthur Blocked By:
Blocking: Platform:
Ready: no Confidential: no
Tester: Verified working: no
Review URL(s):

Description (last modified by saroyanm)

Environment

Model Num.: Nexus 7
Android Version: 4.4.2
Browser: Chrome 32.0.1700.99
Rooted: No
ABP version: Stable/Dev Build
Filter Subscription: Easylist
Acceptable Ads: Off

How to reproduce

  1. Install ABP.
  2. Setup proxy for connected network.
  3. Make sure that "Ads are blocked on WiFi connection" notification exist
  4. Switch Off Acceptable Ads
  5. Navigate to http://thepiratebay.se/browse/102
  6. Navigate to https://www.google.com/#q=laptop

Observed behaviour

Lots of Ads in case of Step 5, Google ads are shown in Step 6

Expected behaviour

All ads are blocked.

Additional Notes

Some strange behavior - Now I only can see ads on this pages (Step 5 and 6) while before I could see them on:
http://winfuture.de/ and some news websites, now I only can reproduce the issue on mentioned websites.
Also Please try to clear Browser Data Before Testing:
Settings -> Privacy -> Clear Browser Data, because I have a doubt that the ads are gone on TPB and appeared after I've Cleared Chrome Data.

Change History (4)

comment:1 Changed 5 years ago by saroyanm

  • Description modified (diff)

comment:2 Changed 5 years ago by saroyanm

Also I've setup Dev Environment on my Laptop, in case some debug logs will be needed.

comment:3 Changed 5 years ago by arthur

  • Cc arthur added

comment:4 Changed 5 years ago by philll

  • Resolution set to worksforme
  • Status changed from new to closed

Step 6 is https, which our proxy cannot intercept. Step 5 did not show any ads with my rooted Nexus 7. I also didn't face any at winfuture. Closing this as worksforme for now, until this is reproducible.

Note: See TracTickets for help on using tickets.