Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#4445 closed defect (fixed)

ABP icon disappears after updating to 2.7.3.4201

Reported by: arthur Assignee:
Priority: P1 Milestone: Adblock-Plus-2.8-for-Firefox
Module: Adblock-Plus-for-Firefox Keywords:
Cc: trev, mapx Blocked By:
Blocking: Platform: Firefox
Ready: yes Confidential: no
Tester: Ross Verified working: yes
Review URL(s):

Description (last modified by trev)

Environment

Nightly 51.0a1 (20160918030408)
ABP 2.7.3.4201
Windows 10 Pro

How to reproduce

  1. Install/Update to the latest dev build

Observed behaviour

The ABP icon disappears from the navigation bar.

Expected behaviour

The icon should stay.

Notes

  • The drop down icon is still clickable
  • Also reproducible with Firefox 48.0.2

Background

In #4409 we set a fixed width and height for the toolbar icon. Turned out, on Windows this toolbar icon has paddings in order to accommodate the dropdown arrow - the resulting content size gets too small because of that. Applying box-sizing: content-box to the element doesn't show any effect, probably because of XUL specifics.

Attachments (1)

Screenshot at 2016-10-01 02-01-10.png (7.3 KB) - added by blackcap95 3 years ago.
Portion of Firefrox 50.0b3 window in Linux Mint 18 showing the effect of the missing ABP icon

Download all attachments as: .zip

Change History (7)

comment:1 Changed 3 years ago by mapx

  • Cc mapx added

comment:2 Changed 3 years ago by mapx

icon disappeared in firefox 49.0 too

comment:3 Changed 3 years ago by fanboy

Maybe related too https://hg.adblockplus.org/adblockplus/rev/8df828ef2894 ?

And yes I'm seeing it too.

Changed 3 years ago by blackcap95

Portion of Firefrox 50.0b3 window in Linux Mint 18 showing the effect of the missing ABP icon

comment:4 Changed 3 years ago by trev

  • Description modified (diff)
  • Milestone set to Adblock-Plus-for-Firefox-next
  • Priority changed from Unknown to P1
  • Ready set
  • Resolution set to fixed
  • Status changed from new to closed

I rolled back the change in question with https://hg.adblockplus.org/adblockplus/rev/14e4e1982152 - it seems that the fix only works on OS X and breaks things on Windows. Currently I don't see any approach that would work with both, the platform-specific Firefox themes are too different.

comment:5 Changed 3 years ago by blackcap95

Verified fixed in Firefox 50.0b4 on Linux Mint 18 MATE.

comment:6 Changed 3 years ago by Ross

  • Tester changed from Unknown to Ross
  • Verified working set

Fixed/rolled back.

ABP 2.7.3.4214-beta
Firefox 45 / 48 / Ubuntu 14.04 (High DPI)
Firefox 38 / 46 / 49 / Windows 7
Firefox Nightly 52.0a1 (2016-10-20) / OS X 10.12

Note: See TracTickets for help on using tickets.