Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#4452 closed defect (fixed)

updateUpdateManifests script errors out failing to import get_certificates_and_key

Reported by: trev Assignee: trev
Priority: P1 Milestone:
Module: Sitescripts Keywords:
Cc: sebastian Blocked By:
Blocking: #4340, #4458 Platform: Unknown / Cross platform
Ready: yes Confidential: no
Tester: Unknown Verified working: no
Review URL(s):

https://codereview.adblockplus.org/29354340/

Description

Background

python -m sitescripts.extensions.bin.updateUpdateManifests currently fails:

  File "/opt/sitescripts/sitescripts/extensions/bin/updateUpdateManifests.py", line 30, in <module>
    from buildtools.packagerSafari import (get_developer_identifier,
ImportError: cannot import name get_certificates_and_key

This is a regression from #4340 and merely went unnoticed so far because the corresponding process on the update server was hanging.

What to change

Update updateUpdateManifests script to use xarfile.read_certificates_and_key().

Change History (4)

comment:1 Changed 3 years ago by trev

  • Review URL(s) modified (diff)
  • Status changed from new to reviewing

comment:3 Changed 3 years ago by trev

  • Resolution set to fixed
  • Status changed from reviewing to closed

comment:4 Changed 3 years ago by trev

  • Blocking 4458 added
Note: See TracTickets for help on using tickets.