Opened 3 years ago

Closed 3 years ago

#4458 closed change (fixed)

Update dependencies for updateUpdateManifests script

Reported by: trev Assignee: trev
Priority: P1 Milestone:
Module: Infrastructure Keywords:
Cc: matze Blocked By: #4340, #4452
Blocking: Platform: Unknown / Cross platform
Ready: yes Confidential: no
Tester: Unknown Verified working: no
Review URL(s):

https://codereview.adblockplus.org/29354719/
https://codereview.adblockplus.org/29354731/

Description

Background

With #4340 and #4452 the updateUpdateManifests script now uses PyCrypto rather than M2Crypto. The update server configuration hasn't been updated yet.

What to change

Make sure to install python-crypto package.

Change History (8)

comment:1 Changed 3 years ago by trev

  • Review URL(s) modified (diff)
  • Status changed from new to reviewing

comment:2 Changed 3 years ago by trev

  • Blocked By 4340, 4452 added

comment:3 Changed 3 years ago by abpbot

A commit referencing this issue has landed:
Issue 4458 - Update dependencies for updateUpdateManifests script

comment:4 Changed 3 years ago by trev

  • Resolution set to fixed
  • Status changed from reviewing to closed

comment:5 Changed 3 years ago by trev

  • Resolution fixed deleted
  • Status changed from closed to reopened

Reopening - the installed version of PyCrypto is too old.

comment:6 Changed 3 years ago by trev

  • Review URL(s) modified (diff)
  • Status changed from reopened to reviewing

comment:8 Changed 3 years ago by trev

  • Resolution set to fixed
  • Status changed from reviewing to closed

Deployed, this will hopefully work now.

Note: See TracTickets for help on using tickets.