Opened 5 years ago

Closed 5 years ago

#445 closed defect (worksforme)

The Download Master program doesn't intercept the link to downloading

Reported by: Advokatvlad Assignee:
Priority: P4 Milestone:
Module: Platform Keywords:
Cc: smultron45@… Blocked By:
Blocking: Platform: Chrome
Ready: yes Confidential: no
Tester: Verified working: no
Review URL(s):

Description (last modified by philll)

Environment

Windows XP
Chrome 35.0.1916.114
ABP 1.8.1 with RuAdlist+Easylist

How to reproduce

  1. Install DownloadMaster ​http://download.downloadmaster.ru/dm/dmaster.exe
  2. Go to ​http://sites.amd.com/us/game/downloads/Pages/radeon_win8-64.aspx
  3. Hit the "Download" button

Observed behavior

Google Chrome displays "Redirected download to DownloadMaster" page. (screenshot in attachment:ABP_DM.JPG). But redirection does not happen.

Expected behavior

A popup from DownloadMaster should appear with the download URL

Attachments (1)

ABP_DM.JPG (30.3 KB) - added by oleksandr 5 years ago.
ABP_DM.jpg

Download all attachments as: .zip

Change History (33)

comment:1 follow-up: Changed 5 years ago by mapx

Can you provide a real test case ? (page link, what do you want to intercept)
"Download Master program" what is it ? an extension, a real installable program ?

comment:2 Changed 5 years ago by mapx

  • Cc smultron45@… added

comment:3 Changed 5 years ago by Advokatvlad

http://westbyte.com/dm/index.phtml - Download Master 5.20.1.1393

http://sites.amd.com/us/game/downloads/Pages/radeon_win8-64.aspx - AMD Radeon™ Desktop Video Card Drivers

comment:4 in reply to: ↑ 1 Changed 5 years ago by Advokatvlad

Replying to mapx:

Can you provide a real test case ? (page link, what do you want to intercept)

http://sites.amd.com/us/game/downloads/Pages/radeon_win8-64.aspx - Catalyst Software Suite 14.4

Replying to mapx:

"Download Master program" what is it ? an extension, a real installable program ?

http://westbyte.com/dm/index.phtml - Download Master 5.20.1.1393

The program integrating expansion in the browser.

http://s43.radikal.ru/i101/1405/fc/85c5b673896d.png

Last edited 5 years ago by Advokatvlad (previous) (diff)

comment:5 Changed 5 years ago by mapx

so, the program adds also an extension in chrome. That extension is not in the chrome store (as I can understand).

comment:6 Changed 5 years ago by Advokatvlad

Yes. Long ago already I use the program. The problem began recently with the Adblock 1.8 version!
If to switch off all dictionaries Adblock and to reboot the browser, the problem isn't present.
Problem in the Adblock dictionaries!

Adblock Warning Removal List
RuAdList+EasyList
EasyPrivacy
Disable Malware
Fanboy's Social Blocking List
Last edited 5 years ago by Advokatvlad (previous) (diff)

comment:7 Changed 5 years ago by philll

Okay, again: Please provide a detailed step by step description of what you did exactly, what you observed and what you expected instead (That is, why we preset those sections for new defect issues in the description fields).

comment:8 follow-up: Changed 5 years ago by mapx

well, with chrome 35 your extension will be disabled (if the authors don't add it to the google store).

comment:9 Changed 5 years ago by Advokatvlad

I use the program for a long time, a problem in the Adblock dictionaries!

The Download Master program doesn't intercept the link to downloading!
If to switch off Adblock Plus that all OK!

Establish Download Master with integration of expansion into the browser and check.

comment:10 in reply to: ↑ 8 Changed 5 years ago by Advokatvlad

Replying to mapx:

well, with chrome 35 your extension will be disabled (if the authors don't add it to the google store).

it is a problem of authors

Last edited 5 years ago by Advokatvlad (previous) (diff)

comment:11 Changed 5 years ago by philll

  • Resolution set to invalid
  • Status changed from new to closed

Apparently, I still cannot understand, what the exact problem is. I am closing this for now, but feel free to reopen if you added a detailed (!) step by step description of what needs to be done to observe which exact issue. Please also provide a description and/or screenshots of which options to select while installing your software, as not all of us speak russian.

comment:12 Changed 5 years ago by Advokatvlad

  • Resolution invalid deleted
  • Status changed from closed to reopened

Replying to philll:

Apparently, I still cannot understand, what the exact problem is. I am closing this for now, but feel free to reopen if you added a detailed (!) step by step description of what needs to be done to observe which exact issue. Please also provide a description and/or screenshots of which options to select while installing your software, as not all of us speak russian.

  1. Establish Google Chrome 34.0.1847.137
  2. Establish Download Master 5.20.1.1393
  3. Download drivers Catalyst Software Suite 14.4
Version 1, edited 5 years ago by Advokatvlad (previous) (next) (diff)

comment:13 follow-up: Changed 5 years ago by philll

Okay, but what exactly happens if you try to download this driver suite and what do you expect to happen instead?

comment:14 in reply to: ↑ 13 Changed 5 years ago by Advokatvlad

Replying to philll:

Okay, but what exactly happens if you try to download this driver suite and what do you expect to happen instead?

Download Master 5.20.1.1393 for loading isn't started!

Last edited 5 years ago by Advokatvlad (previous) (diff)

comment:15 Changed 5 years ago by mapx

@advokatvlad,
could you test the last dev build ?
first disable ABP 1.8.1 (stable build) ==> go to extensions page (tools, extensions) and disable it

then install dev build from:
https://chrome.google.com/webstore/detail/ldcecbkkoecffmfljeihcmifjjdoepkn

Last edited 5 years ago by mapx (previous) (diff)

comment:16 Changed 5 years ago by Advokatvlad

The good decision, but I can't check, since a problem in Adblock instead of Google Chrome!

comment:17 Changed 5 years ago by mapx

...?! what problem ?

comment:18 Changed 5 years ago by Advokatvlad

I don't want to adjust the browser anew.

comment:19 Changed 5 years ago by mapx

well, it's simple what I asked you to do.
This way (using dev build) we can see if the last changes have solved also your issue.

comment:20 Changed 5 years ago by Advokatvlad

Probably also will solve a problem. Thanks. But I won't establish since I don't use DEV the version!
Try to check at first as I described on the stable version of the browser.

Last edited 5 years ago by Advokatvlad (previous) (diff)

comment:21 follow-up: Changed 5 years ago by oleksandr

I have been able to reproduce the problem on Chrome. Works fine on Firefox and IE.
With ABP enabled, Chrome does not redirect the download to Download Manager, but rather silently loads the "Redirecting to DLM page" and stays there.

It looks like ABP is blocking just one item on the page:
http://sites.amd.com/PublishingImages/Restricted/game/master_main.jpg

If I disable ABP just on the site, the download works fine.

comment:22 in reply to: ↑ 21 Changed 5 years ago by mapx

Replying to oleksandr:

I have been able to reproduce the problem on Chrome. Works fine on Firefox and IE.
With ABP enabled, Chrome does not redirect the download to Download Manager, but rather silently loads the "Redirecting to DLM page" and stays there.

It looks like ABP is blocking just one item on the page:
http://sites.amd.com/PublishingImages/Restricted/game/master_main.jpg

If I disable ABP just on the site, the download works fine.

Did you try using the last ABP dev build for chrome ?

comment:23 Changed 5 years ago by saroyanm

Had no chance to test with Chrome V 34.0.1847.131 m

But tested with chrome V 33 and V 35.0.1916.114

Chrome does not redirect the download to Download Manager with and without ABP in both versions (33 and 35), until I'm not using "Download link" button from right click context menu, while it's work okey in FireFox by just clicking on "Download" button in ​http://sites.amd.com/us/game/downloads/Pages/radeon_win8-64.aspx .

So, can't reproduce on my side.

comment:24 Changed 5 years ago by oleksandr

V 35.0.1916.114 here as well. Works fine with ABP disabled if I just click Download button. Does not work with ABP enabled.

I'm testing on virtual machine with Windows XP. Maybe that's the difference.

Changed 5 years ago by oleksandr

ABP_DM.jpg

comment:25 Changed 5 years ago by oleksandr

  • Ready set

Environment:
Windows XP SP3, AdblockPlus for Chrome 1.8.1., filterlist: RuAdlist+Easylist

How to reproduce:

  1. Install Google Chrome https://www.google.com/intl/en/chrome/browser/
  2. Install AdblockPlus for Chrome
  3. Install DownloadMaster http://download.downloadmaster.ru/dm/dmaster.exe
  4. Go to http://sites.amd.com/us/game/downloads/Pages/radeon_win8-64.aspx and hit the "Download" button.

Observed behavior:

Google Chrome displays "Redirected download to DownloadMaster" page. (screenshot attached ABP_DM.jpg). No image "ABP_DM.jpg" attached to Ticket #445

But redirection does not happen.

Expected behavior:

A popup from DownloadMaster should appear with the download URL

Last edited 5 years ago by oleksandr (previous) (diff)

comment:26 Changed 5 years ago by philll

  • Description modified (diff)

comment:27 Changed 5 years ago by philll

  • Description modified (diff)

comment:28 Changed 5 years ago by philll

  • Description modified (diff)

comment:29 Changed 5 years ago by philll

  • Platform set to Chrome

comment:30 Changed 5 years ago by sebastian

  • Component changed from Unknown to Platform
  • Priority changed from Unknown to P4

comment:31 Changed 5 years ago by oleksandr

Looks like this is no longer an issue. Works fine with the latest versions of both apps. ABP 1.8.12 and Download Master 6.2.2.1449.

comment:32 Changed 5 years ago by sebastian

  • Resolution set to worksforme
  • Status changed from reopened to closed
Note: See TracTickets for help on using tickets.