Opened 3 years ago

Closed 3 years ago

#4460 closed change (rejected)

Update buildtools dependency to revision 512717e74592

Reported by: trev Assignee: trev
Priority: P1 Milestone:
Module: Sitescripts Keywords:
Cc: sebastian Blocked By:
Blocking: Platform: Unknown / Cross platform
Ready: yes Confidential: no
Tester: Unknown Verified working: no
Review URL(s):

Description

Background

We need get the #4459 change into sitescripts in order to fix updateUpdateManifest script with older versions of PyCrypto. In addition, #4382 will be imported, minimal adjustment to Python syntax. The other issues (#4375, #4047, #4353) are irrelevant for sitescripts.

What to change

Updating dependency and running ensure_dependencies.py should be sufficient.

Change History (4)

comment:1 Changed 3 years ago by abpbot

A commit referencing this issue has landed:
Issue 4460 - Update buildtools dependency to revision 512717e74592

comment:2 Changed 3 years ago by trev

  • Resolution set to fixed
  • Status changed from new to closed

comment:3 Changed 3 years ago by trev

  • Resolution fixed deleted
  • Status changed from closed to reopened

Rolled back in https://hg.adblockplus.org/sitescripts/rev/560ea86e9429, this isn't sufficient to support PyCrypto 2.4 on the server so we need to get a newer version there.

comment:4 Changed 3 years ago by trev

  • Resolution set to rejected
  • Status changed from reopened to closed
Note: See TracTickets for help on using tickets.