Opened 3 years ago

Closed 3 years ago

#4464 closed defect (fixed)

updateUpdateManifests script relies on sitescripts.extensions.android which is no longer there

Reported by: trev Assignee: kvas
Priority: P2 Milestone:
Module: Sitescripts Keywords:
Cc: sebastian, kvas Blocked By:
Blocking: #3759 Platform: Unknown / Cross platform
Ready: yes Confidential: no
Tester: Unknown Verified working: no
Review URL(s):

https://codereview.adblockplus.org/29354748/

Description (last modified by sebastian)

How to reproduce

  1. Create a clean copy of sitescripts repository.
  2. Run python -m sitescripts.extensions.bin.updateUpdateManifests

Observed behaviour

The script errors out, it attempts to import from sitescripts.extensions.android module which was removed in #3759.

Expected behaviour

No errors. Currently, this is only working on the server because of a stale android.pyc file.

What to change

Add the get_min_sdk_version() function from the removed sitescripts.extensions.android module to sitescripts.extensions.bin.updateUpdateManifests, and remove the dead import.

Change History (9)

comment:1 Changed 3 years ago by sebastian

  • Cc kvas added
  • Priority changed from Unknown to P2
  • Ready set

comment:2 Changed 3 years ago by sebastian

  • Component changed from Unknown to Sitescripts

comment:3 Changed 3 years ago by sebastian

  • Description modified (diff)

comment:4 Changed 3 years ago by sebastian

  • Description modified (diff)

comment:5 Changed 3 years ago by sebastian

  • Description modified (diff)

comment:6 Changed 3 years ago by kvas

  • Owner set to kvas

comment:7 Changed 3 years ago by kvas

  • Review URL(s) modified (diff)
  • Status changed from new to reviewing

comment:9 Changed 3 years ago by kvas

  • Resolution set to fixed
  • Status changed from reviewing to closed
Note: See TracTickets for help on using tickets.