Opened 3 years ago

Closed 3 years ago

#4481 closed defect (duplicate)

Footer menu isn't working in the blog (width < 1000 view)

Reported by: trev Assignee: trev
Priority: P3 Milestone:
Module: Unknown Keywords:
Cc: Blocked By:
Blocking: #4293 Platform: Unknown / Cross platform
Ready: yes Confidential: no
Tester: Unknown Verified working: no
Review URL(s):

https://codereview.adblockplus.org/29355239/

Description

How to reproduce

  1. Go to https://adblockplus.org/blog/ and scroll down.
  2. Make your browser window smaller in order to get the compact view (footer entries as menus).
  3. Click on "Resources."

Observed behaviour

Nothing happens. There is an error in console:

TypeError: language is null
main.js line 51

Expected behaviour

The menu should open, like on the home page.

Background

main.js initializes language selector before initializing the footer. Problem is, the blog doesn't have a language selector so that function errors out and the footer stays uninitialized.

Change History (4)

comment:1 Changed 3 years ago by trev

  • Owner set to trev

comment:2 Changed 3 years ago by trev

  • Review URL(s) modified (diff)
  • Status changed from new to reviewing

comment:3 Changed 3 years ago by saroyanm

  • Priority changed from Unknown to P3
  • Ready set

comment:4 Changed 3 years ago by trev

  • Resolution set to duplicate
  • Status changed from reviewing to closed

Duplicate of #4189.

Note: See TracTickets for help on using tickets.