Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#4499 closed defect (fixed)

$generichide does not work in ABP 2.7.3.4204-beta

Reported by: mapx Assignee: trev
Priority: P1 Milestone: Adblock-Plus-2.8-for-Firefox
Module: Adblock-Plus-for-Firefox Keywords:
Cc: trev, kzar Blocked By:
Blocking: #524 Platform: Firefox
Ready: yes Confidential: no
Tester: Ross Verified working: yes
Review URL(s):

https://codereview.adblockplus.org/29356270/

Description (last modified by mapx)

Environment

firefox Version 2.7.3.4204-beta
easylist
windows 10

How to reproduce

go to
http://www.porjati.net/scary_stories/24959-chtoby-pomnili-posledniy-boy-svyazista-podvig-viktora-yacenevicha.html

add @@||porjati.net^$generichide

In the blockable items list I still can see generic filters
##.pub_300x250
##div[id^="MarketGid"]

If I add an exception filter
porjati.net#@#div[id^="MarketGid"]

I get no hits on such filter in the custom filters list.

Instead, $elemhide is working.

Could be a regression due to #524 ?
https://codereview.adblockplus.org/29356078/

In ABP for chrome $generichide is working fine.

Change History (6)

comment:1 Changed 3 years ago by mapx

  • Description modified (diff)

comment:2 Changed 3 years ago by trev

  • Blocking 524 added
  • Owner set to trev
  • Priority changed from Unknown to P1
  • Ready set

Yes, definitely a regression from #524. New code is considering the scenario where element hiding is disabled completely but I forgot that on some sites it should be non-generic only.

comment:3 Changed 3 years ago by trev

  • Review URL(s) modified (diff)
  • Status changed from new to reviewing

comment:5 Changed 3 years ago by trev

  • Milestone set to Adblock-Plus-for-Firefox-next
  • Resolution set to fixed
  • Status changed from reviewing to closed

comment:6 Changed 3 years ago by Ross

  • Tester changed from Unknown to Ross
  • Verified working set

Fixed.

ABP 2.7.3.4214-beta
Firefox 38 / 46 / 49 / Windows 7

Note: See TracTickets for help on using tickets.