Opened 3 years ago

Closed 3 years ago

#4500 closed defect (fixed)

Element hiding integration tests broken

Reported by: trev Assignee: trev
Priority: P2 Milestone:
Module: Extensions-for-Adblock-Plus Keywords:
Cc: Blocked By:
Blocking: #521 Platform: Unknown / Cross platform
Ready: yes Confidential: no
Tester: Unknown Verified working: no
Review URL(s):

https://codereview.adblockplus.org/29356283/

Description

How to reproduce

  1. Install Adblock Plus Tests extension from adblockplustests repository.
  2. Go to extension preferences, choose "elemhide" and click Run.

Observed behaviour

All tests fail because ElemHide.apply() no longer exists as of #521.

Expected behaviour

Tests should pass.

What to change

This test should not mess with the internals of ElemHide, it should rather add the necessary filters to FilterStorage. Also, the asynchronous behavior of ElemHide is gone as of #521 so loading the frame immediately after adding the filters is fine.

Change History (3)

comment:1 Changed 3 years ago by trev

  • Review URL(s) modified (diff)
  • Status changed from new to reviewing

comment:2 Changed 3 years ago by abpbot

A commit referencing this issue has landed:
Issue 4500 - Fix element hiding integration tests

comment:3 Changed 3 years ago by trev

  • Resolution set to fixed
  • Status changed from reviewing to closed
Note: See TracTickets for help on using tickets.