Opened 3 years ago

Closed 3 years ago

#4501 closed defect (fixed)

Filters with key 0 stay "unconditional" even after an exception is added

Reported by: trev Assignee: trev
Priority: P1 Milestone:
Module: Core Keywords:
Cc: Blocked By:
Blocking: #4450 Platform: Unknown / Cross platform
Ready: yes Confidential: no
Tester: Unknown Verified working: no
Review URL(s):

https://codereview.adblockplus.org/29356322/

Description

How to reproduce

  1. With a completely empty filter list, add ##test and then example.com#@#test.
  2. Open example.com.

Observed behaviour

The filter ##test still applies on example.com. The code which should mark it as no more unconditional fails because its filter key is 0.

Expected behaviour

The filter ##test should no longer apply.

Change History (3)

comment:1 Changed 3 years ago by trev

  • Review URL(s) modified (diff)
  • Status changed from new to reviewing

comment:2 Changed 3 years ago by abpbot

comment:3 Changed 3 years ago by trev

  • Resolution set to fixed
  • Status changed from reviewing to closed
Note: See TracTickets for help on using tickets.