Opened 3 years ago

Closed 3 years ago

#4517 closed defect (worksforme)

Acceptable Ads inconsistently functions on Android 21+

Reported by: scheer Assignee:
Priority: Unknown Milestone:
Module: Adblock-Plus-for-Android Keywords:
Cc: mario, Anton Blocked By:
Blocking: Platform: Android
Ready: no Confidential: no
Tester: Scheer Verified working: no
Review URL(s):

Description

With the current Lightning browser integration, Acceptable ads are meant to function on Android 21+, but not on Android 17. Whilst testing with an Android 21+ device, I found that Acceptable Ads is inconsistent in its function and will only show acceptable ads in some situations.

From what I observe, it is almost as though the browser can only view either the AA list and apply it, or the Easylist and apply it. But, both don't appear to function together.

LogCat attached.

Environment

ABP for Lightning 4.3.3
Galaxy S7
Android 6.0.1
API 23

How to reproduce

  1. Load www.google.de
  2. Search for 'iPhone 6'
  3. Load www.google.co.uk
  4. Search 'iPhone 6'
  5. Close the browser
  6. Load the browser

Observed behaviour

Following the steps above, Acceptable ads do not function consistently.

Expected behaviour

Acceptable Ads should work in all of the above-given examples.

Attachments (4)

AA Log Cat Android 6.0.1.txt (19.8 KB) - added by scheer 3 years ago.
google-play-aa_de.png (200.5 KB) - added by asmirnov 3 years ago.
de
google-play-aa_co_uk.png (210.2 KB) - added by asmirnov 3 years ago.
co_uk
google-play-aa_co_uk-2.png (185.7 KB) - added by asmirnov 3 years ago.
co uk #2 - no aa shown

Download all attachments as: .zip

Change History (8)

Changed 3 years ago by scheer

Changed 3 years ago by asmirnov

de

Changed 3 years ago by asmirnov

co_uk

Changed 3 years ago by asmirnov

co uk #2 - no aa shown

comment:1 Changed 3 years ago by asmirnov

i've tested with app installed from google play and AA was shown for de, shown for co.uk for the first time, NOT shown for co.uk after browser closed/started (see the screenshots attached).

So it looks like it's not ABP integration issue.

comment:2 Changed 3 years ago by scheer

@asmimov - Correct me if I am wrong, but the store version doesn't have any form of ABP integration, so Acceptable Ads should not work there anyway?

This use case can only be applied to the integrated version.

comment:3 Changed 3 years ago by asmirnov

Correct, Google Play version does not have any kind of ABP integration, but it has primitive domain filtering. I believe all the ads including Acceptable Ads is shown there (not sure what you mean "AA .. work ..").

comment:4 Changed 3 years ago by scheer

  • Resolution set to worksforme
  • Status changed from new to closed
  • Tester changed from Unknown to Scheer

I am no longer able to reproduce this on Adblock Plus for Lightning Browser (93).

Note: See TracTickets for help on using tickets.