Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#4518 closed defect (fixed)

Acceptable Ad links do not load after selection on Android 21+

Reported by: scheer Assignee:
Priority: Unknown Milestone:
Module: Adblock-Plus-for-Android Keywords:
Cc: mario, Anton Blocked By:
Blocking: Platform: Android
Ready: no Confidential: no
Tester: Scheer Verified working: yes
Review URL(s):

https://codereview.adblockplus.org/29351744/#ps29357527

Description (last modified by asmirnov)

When selecting an inline search ad from a Google search in the newly integrated ABP for Lightning Browser, the page should load either a new tab with the advert link and display the ad page correctly, or load the ad page in the current tab. Currently, when selecting an ad from a Google search, the link is inputted in the address bar, but the page is not loaded.

With the current issue #4517, you might need to search a few times to have an Acceptable Ad appear.

--With the latest integration Version (91), this still occurs. However, by disabling Adblock Plus and Acceptable Ads from Settings>Adblock Plus Settings, the ad loads correctly in it's current window.--

Environment

ABP for Lightning 4.3.3 (90)
ABP for Lightning 4.3.3 (91)
Galaxy S7
Android 6.0.1
API 23

How to reproduce

  1. Search for 'iPhone 6' on www.google.com
  2. Select one of the inline ads

Observed behaviour

A blank page is shown with ad URL in address bar.

Expected behaviour

Ad page is shown.

Attachments (6)

Log Cat Blank Ad Page.txt (16.0 KB) - added by scheer 3 years ago.
Screenshot_20161011-101732.png (641.7 KB) - added by scheer 3 years ago.
Screenshot_20161011-101804.png (137.6 KB) - added by scheer 3 years ago.
aa-1.png (254.5 KB) - added by asmirnov 3 years ago.
aa shown
aa-2.png (467.9 KB) - added by asmirnov 3 years ago.
followed AA link 1
AdblockWebView Lightning Browser (93) NON Play Version #4518.txt (75.4 KB) - added by scheer 3 years ago.

Download all attachments as: .zip

Change History (15)

Changed 3 years ago by scheer

Changed 3 years ago by scheer

Changed 3 years ago by scheer

comment:1 Changed 3 years ago by asmirnov

  • Description modified (diff)

Changed 3 years ago by asmirnov

aa shown

Changed 3 years ago by asmirnov

followed AA link 1

comment:2 Changed 3 years ago by asmirnov

There are no log entries for "AdblockWebView" tag in the attached log - please make sure you're getting log output for it.
Also i was unable to reproduce it - i was able to navigate to open of the shops advertised with AA (see attached screenshots).

comment:3 Changed 3 years ago by scheer

  • Description modified (diff)

@asmirnov - I have attached the logs for the example I gave above in how to reproduce this issue. Re-testing this in the latest integration version (93) it still occurs, however, if I disable Adblock Plus via the new Adblock menu (also disable Acceptable Ads), then the page loads just fine.

I will update the issue above.

With your example, it appears you are searching for a Galaxy S7. Does this also work for you with my above-given reproduction steps? This could well be an Android version issue again.

comment:4 Changed 3 years ago by asmirnov

Here is the error log entry:

10-12 11:25:15.826 32143-32143/acr.browser.barebones E/AdblockWebView: Load error: code=-1 with description=There was a network error. for url=https://www.google.de/aclk?sa=l&ai=DChcSEwjWmpWP-dTPAhXGlRsKHbVWBJAYABAA&sig=AOD64_3fD32cRXD--AlAMIGVR7uVLZlTjw&q=&ved=0ahUKEwjAppKP-dTPAhVLQBQKHTBnBO0Q0QwIIg&adurl=

It means that loading error happened and WebViewClient was notified, not sure if/how it's affected by ABP integration

comment:5 Changed 3 years ago by asmirnov

Here is the reason:

10-12 11:25:15.816 32143-32186/acr.browser.barebones W/AdblockWebView: Blocked loading https://www.google.de/aclk?sa=l&ai=DChcSEwjWmpWP-dTPAhXGlRsKHbVWBJAYABAA&sig=AOD64_3fD32cRXD--AlAMIGVR7uVLZlTjw&q=&ved=0ahUKEwjAppKP-dTPAhVLQBQKHTBnBO0Q0QwIIg&adurl=

It means FilterEngine blocked loading it, will check it

comment:6 Changed 3 years ago by asmirnov

  • Description modified (diff)

comment:7 Changed 3 years ago by asmirnov

  • Resolution set to fixed
  • Review URL(s) modified (diff)
  • Status changed from new to closed

comment:8 Changed 3 years ago by asmirnov

updated test browser at testobject to 92. Please confirm

comment:9 Changed 3 years ago by scheer

  • Tester changed from Unknown to Scheer
  • Verified working set

ABP for Lightning 4.3.3 (92)
Galaxy S7
Android 6.0.1
API 23

Note: See TracTickets for help on using tickets.