Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#453 closed defect (worksforme)

[Chrome] Persistent loading icon when viewing pdf

Reported by: arthur Assignee:
Priority: P2 Milestone:
Module: Platform Keywords:
Cc: smultron45@… Blocked By:
Blocking: Platform:
Ready: yes Confidential: no
Tester: Verified working: no
Review URL(s):

Description

Environment

Windows 8.1 Pro x64 Update 1
Chrome 34.0.1847.131 m
ABP 1.8.1 or 1.8.1.1182
Only EasyList enabled

How to reproduce

  1. Open a PDF file (e. g. http://kim.com/whitepaper.pdf)

Observed behaviour

The loading icon doesn't stop.

To reproduce this again you might need to clear the cache. It seem to only appear with EasyList enabled but the ad counter doesn't show anyhing blocked.

Expected behaviour

It should disappear once the PDF is fully loaded.

Forum topic

https://adblockplus.org/forum/viewtopic.php?f=10&t=23030

Change History (9)

comment:1 Changed 5 years ago by philll

  • Priority changed from P4 to P3

Even worse: In many cases of trying to open the PDF, the Chrome tab of Chrome 34.0.1847.131 m crashed immediately. Chrome 35.0.1916.99 beta-m shows the described bug behaviour but doesn't crash the tab.

comment:2 Changed 5 years ago by mapx

  • Cc smultron45@… added

comment:3 Changed 5 years ago by philll

  • Priority changed from P3 to P2

Also occures with http://images.apple.com/legal/sla/docs/OSX109.pdf, even Chrome 35 crashed immediately in my test environment with Win 7 Enterprise. However, with https://bitcoin.org/bitcoin.pdf, I am just facing the described issue, but no crashs.

comment:4 follow-up: Changed 5 years ago by nino

I am new here. How can I add my name to the cc list? (Which I presume is the notification list for updates)

comment:5 Changed 5 years ago by mapx

it seems the issue was the same here:
#1188: 2014-05-14 16:25 +0200 Sebastian Noack
Issue 450 - Create shadow root immediatelly instead inside the reponse callback

it's working with the last dev build (1188)

comment:6 in reply to: ↑ 4 Changed 5 years ago by mapx

Replying to nino:

I am new here. How can I add my name to the cc list? (Which I presume is the notification list for updates)

it's not possible for all users, there is a ...ticket still in waiting:
https://issues.adblockplus.org/ticket/272

comment:8 Changed 5 years ago by philll

  • Resolution set to worksforme
  • Status changed from new to closed

I just retested the issue with the current dev build 1.8.2.1188 and could not reproduce the issue any longer.

comment:9 Changed 5 years ago by sebastian

This was fixed with #450.

Note: See TracTickets for help on using tickets.