Opened 8 months ago

Closed 8 months ago

Last modified 8 months ago

#4533 closed defect (fixed)

Element Hiding Helper button is gone from Inspector toolbar

Reported by: magicp Assignee: trev
Priority: P1 Milestone: Element-Hiding-Helper-1.3.10
Module: Extensions-for-Adblock-Plus Keywords:
Cc: trev, mapx Blocked By:
Blocking: Platform: Firefox
Ready: yes Confidential: no
Tester: Ross Verified working: yes
Review URL(s):

https://codereview.adblockplus.org/29357569/

Description (last modified by trev)

Platform: Windows, Linux and Mac OS X
Firefox: 52.0a1 Nightly
Adblock Plus 2.7.3
Element Hiding Helper 1.3.9

STR:

  1. Start latest Nightly with Adblock Plus and Element Hiding Helper
  2. Open DevTools > Inspector
  3. Check the Element Hiding Helper button in Inspector toolbar

Actual result

Element Hiding Helper button is gone from Inspector toolbar

Expected result

The Element Hiding Helper button will be displayed in Inspector toolbar

Background

Developer tools switched from XUL to HTML. We are creating our button with the default namespace however which is no longer XUL now.

Attachments (1)

attachment-to-ticket-4533.png (70.2 KB) - added by magicp 8 months ago.

Download all attachments as: .zip

Change History (10)

Changed 8 months ago by magicp

comment:1 Changed 8 months ago by mapx

  • Cc trev mapx added

comment:3 Changed 8 months ago by trev

No, this isn't fixed in the development builds - I can reproduce this, seems to be a recent regression.

comment:4 Changed 8 months ago by trev

The button is there, right next to the "plus" icon. However, it has no image because our styles don't apply for some reason. Also, clicking it doesn't seem to do anything.

comment:5 Changed 8 months ago by trev

  • Component changed from Unknown to Extensions-for-Adblock-Plus
  • Description modified (diff)
  • Owner set to trev
  • Priority changed from Unknown to P1
  • Ready set

comment:6 Changed 8 months ago by trev

  • Review URL(s) modified (diff)
  • Status changed from new to reviewing

comment:7 Changed 8 months ago by abpbot

comment:8 Changed 8 months ago by trev

  • Milestone set to Element-Hiding-Helper-1.3.10
  • Resolution set to fixed
  • Status changed from reviewing to closed

comment:9 Changed 8 months ago by Ross

  • Tester changed from Unknown to Ross
  • Verified working set

Fixed in Nightly. Still working in previous versions.

Firefox 38 / 48 / Nightly 52.0a1 (2016-10-23)
Firefox 45 / Ubuntu 14.04

Note: See TracTickets for help on using tickets.