Opened 3 years ago

Closed 3 years ago

Last modified 17 months ago

#4534 closed defect (fixed)

Samsung Browser stops working when Russian Easylist is active.

Reported by: scheer Assignee:
Priority: Unknown Milestone:
Module: Adblock-Plus-for-Samsung-Browser Keywords:
Cc: vickyyu, mario, diegocarloslima, arthur Blocked By:
Blocking: Platform: Samsung Browser
Ready: no Confidential: no
Tester: Unknown Verified working: no
Review URL(s):

Description

When the user selects the Russian Filter list from 'Configure your filter lists' in ABP for Sbrowser and then opens Samsung Browser, after 2-3 seconds, Samsung browser stops working.

After testing this against all other lists available, the Russian list is currently the only one with this issue.

Environment

ABP for SBrowser 1.0.3 (Google Play Store Current)
Samsung Browser 4.0.20-73
Galaxy S7
Android 6.0.1

How to reproduce

  1. Enable the Russian Filter list in ABP for Sbrowser
  2. Open Samsung Browser
  3. Wait 2-3 seconds

Observed behaviour

'Unfortunately, Internet has stopped' message appears and the browser is closed.

Expected behaviour

Samsung Browser continues to function as normal

Attachments (1)

Russian Filter List Crash.txt (530.5 KB) - added by scheer 3 years ago.

Download all attachments as: .zip

Change History (6)

Changed 3 years ago by scheer

comment:1 Changed 3 years ago by scheer

  • Cc arthur added

comment:2 Changed 3 years ago by diegocarloslima

The issue is related to recent changes that were made on ruadlist: 067d5bbdcf6b and 9483b9d44743 when two rules wih |$websocket were introduced. The Samsung Internet app fails to parse these rules when reading the file and crashes.

Version 0, edited 3 years ago by diegocarloslima (next)

comment:3 Changed 3 years ago by diegocarloslima

  • Resolution set to fixed
  • Status changed from new to closed

This issue was fixed in 200b70a01d50

comment:4 Changed 17 months ago by mario

  • Milestone set to Adblock-Plus-for-Samsung-Browser-1.1.3

Adjusted milestone of unassigned, closed issues of ABP/SI

comment:5 Changed 17 months ago by mario

  • Milestone Adblock-Plus-for-Samsung-Browser-1.1.3 deleted

Reverted incorrect assignment to current milestone

Note: See TracTickets for help on using tickets.