Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#4538 closed change (fixed)

When exporting filters, mark $websocket filters as requiring Adblock Plus 2.8

Reported by: trev Assignee: trev
Priority: P1 Milestone: Adblock-Plus-2.8-for-Firefox
Module: Adblock-Plus-for-Firefox Keywords:
Cc: Ross Blocked By:
Blocking: Platform: Unknown / Cross platform
Ready: yes Confidential: no
Tester: Unknown Verified working: no
Review URL(s):

https://codereview.adblockplus.org/29357587/

Description (last modified by trev)

Background

We introduced $websocket filter type in #4449, meaning that it will be released with Adblock Plus 2.8.

What to change

When exporting custom filters only, make sure to use [Adblock Plus 2.8] header whenever a $websocket filter is present.

Change History (6)

comment:1 Changed 3 years ago by trev

  • Description modified (diff)
  • Review URL(s) modified (diff)
  • Status changed from new to reviewing

comment:3 Changed 3 years ago by trev

  • Milestone set to Adblock-Plus-2.8-for-Firefox
  • Resolution set to fixed
  • Status changed from reviewing to closed

comment:4 Changed 3 years ago by Ross

This is working in Firefox 45, 49, 52 (various headers depending on filters). But Firefox 38 seems to always put a 2.8 header no matter which filters are present.

comment:5 Changed 3 years ago by trev

  • Cc Ross added

Ross, I cannot reproduce that. In Firefox 38 on macOS 10.12, when I exported filters initially I got "[Adblock Plus 2.0]" header. I then added foobar$websocket filter and got "[Adblock Plus 2.8]" header. Once I removed that filter it was "[Adblock Plus 2.0]" again. Also, I don't really see how this code could depend on the Firefox version. Are you certain that your export didn't have a $websocket filter?

comment:6 Changed 3 years ago by Ross

Pretty certain as I'd done a fresh install several times and added just a really basic filter. However I can't reproduce it at all in the latest build (2.8.1.2222) so I'll retest again in a 4X/Nightly version too then verify this. Thanks for checking!

Note: See TracTickets for help on using tickets.