Opened 2 years ago

Closed 2 years ago

#4546 closed defect (worksforme)

Sbrowser is not opened from ABP after Sbrowser update

Reported by: scheer Assignee:
Priority: Unknown Milestone:
Module: Adblock-Plus-for-Samsung-Browser Keywords:
Cc: diegocarloslima, vickyyu Blocked By:
Blocking: Platform: Samsung Browser
Ready: no Confidential: no
Tester: Unknown Verified working: no
Review URL(s):

Description

As shown in #3995 the user is presented with a message asking them to update to Samsung Internet 4.0 and higher to be able to use ABP for SBrowser.

Currently, after upgrading, opening and then completing the first run screen of Sbrowser, the user should be able to re-launch ABP and then select'Configure Samsung Browser settings' and be taken directly to the option of enabling the Blocking Functionality within Sbrowser itself.

However, when the user currently selects 'Configure Samsung Browser settings', ABP blinks and remains on the setting screen and Sbrowser is not opened.

Environment

ABP for Sbrowser 1.0.4
Galaxy S4
Android 5.0.1

How to reproduce

  1. Have Sbrowser 4.0 or lower installed
  2. Install ABP 1.0.4
  3. Select 'Get update'
  4. Select 'Update'
  5. Select 'Open'
  6. Go past first run screens
  7. Open ABP and select 'Got it'
  8. Select 'Configure Samsung Browser settings'

Observed behaviour

Samsung Browser is not opened and the user remains on the ABP settings screen.

Expected behaviour

User is directed to the settings page and is able to enable ABP in the Content Blockers section.

Attachments (1)

TestObject_Log_Samsung_I9505_Galaxy_S4_real_18-10-2016_11-00-12.txt (4.4 MB) - added by scheer 2 years ago.

Download all attachments as: .zip

Change History (3)

comment:1 Changed 2 years ago by diegocarloslima

It looks like it's an issue with the APK signing, the Samsung Internet app queries for a list of approved signatures and compares with the one in the APK and only if it matches that it accepts the 'Configure Samsung Browser Settings' call. TestObject may have changed the signature of the APK, making it behave like that.

comment:2 Changed 2 years ago by scheer

  • Resolution set to worksforme
  • Status changed from new to closed

Trying it out on a real Galaxy S4, Android 5.0.1, the process works. It could well be that Test Object resigning caused some issues here.

Because of the above, I will close this issue.

Note: See TracTickets for help on using tickets.