Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#4550 closed defect (fixed)

ABP / edge loses some filterlist subscriptions

Reported by: mapx Assignee:
Priority: P1 Milestone: Adblock-Plus-0.9.9-for-Microsoft-Edge
Module: Platform Keywords:
Cc: oleksandr, sebastian Blocked By:
Blocking: Platform: Edge
Ready: yes Confidential: no
Tester: Ross Verified working: yes
Review URL(s):

https://codereview.adblockplus.org/29358499/

Description (last modified by oleksandr)

Environment

windows 10
last edge
ABP 0.9.8

How to reproduce

add initial subscription in the options page
add another subscription or add custom fitlers
close edge
open edge

Observer the last added subscription or custom filters disappeared

see the dedicated edge subforum for the complains
https://adblockplus.org/forum/viewforum.php?f=27

What to change

It looks like we are not loading the last stored subscription after Edge restart. Make sure it is being loaded.

Change History (6)

comment:1 Changed 3 years ago by oleksandr

  • Component changed from Unknown to Platform
  • Ready set
  • Review URL(s) modified (diff)
  • Status changed from new to reviewing

comment:2 Changed 3 years ago by sebastian

  • Milestone set to Milestone Adblock-Plus-0.9.9-for-Microsoft-Edge
  • Resolution set to fixed
  • Status changed from reviewing to closed

comment:3 Changed 3 years ago by sebastian

  • Priority changed from Unknown to P1

comment:4 Changed 3 years ago by abpbot

A commit referencing this issue has landed:
Issue 4550 - ABP / edge loses the custom filters / lists

comment:5 Changed 3 years ago by oleksandr

  • Description modified (diff)
  • Summary changed from ABP / edge loses the custom filters / lists to ABP / edge loses some filterlist subscriptions

comment:6 Changed 3 years ago by Ross

  • Tester changed from Unknown to Ross
  • Verified working set

Fixed. However there is still an issue with the state of subscriptions (#4562).

ABP Edge 0.9.9
Edge 38.14393.0.0 / Windows 10

Note: See TracTickets for help on using tickets.