Opened 9 months ago

Closed 7 months ago

Last modified 5 months ago

#4554 closed change (fixed)

Update ABP bundle to version 1.12.4

Reported by: mario Assignee:
Priority: P2 Milestone: Adblock-Browser-for-iOS-1.5.2
Module: Adblock-Browser-for-iOS Keywords:
Cc: Blocked By:
Blocking: Platform: Adblock Browser for iOS
Ready: no Confidential: no
Tester: Scheer Verified working: yes
Review URL(s):

Description

Background

Since the last dependency update we have released two minor updates of ABP for Chrome/Opera/Safari:

In order to stay up to date, we want to update the ABP bundle in ABB.

What to change

Replace the ABP extension bundle with the provided crx file based on ABP 1.12.4 for Chrome/Opera/Safari.

Remarks

ABP 1.12.1 as well as 1.12.2 introduce changes/fixes which may need to be taken into consideration during implementation and QA.
Specifically the following issues might directly/indirectly affect ABB's behaviour:

  • #4361 - ABP calls Event#initEvent without all required parameters, breaking Safari TP r11
  • #4386 - Document domain determined incorrectly after a redirect
  • #4372 - Prevent advanced WebSocket circumvention where our content scripts can't run
  • #4448 - Use 'websocket' type for WebSocket connections
  • #4295 - Update adblockplusui dependency to revision 53626d2055a6
  • #4364 - Drop support for Chrome 29-40 and remove legacy code
  • #4466 - Update adblockpluscore dependency, replace rsa.js with rsa module
  • #4351 - Update adblockpluscore dependency, replace rsa.js with rsa module
  • #4477 - Update adblockpluscore dependency and getSelectorsForDomain usage

Change History (6)

comment:1 Changed 8 months ago by pavelz

https://www.pivotaltracker.com/story/show/134161947
kitt-core story to supply missing webNavigation.onCommitted chrome API required by #4386

comment:2 Changed 8 months ago by pavelz

  • Keywords blocked added

Ignore the following. I have mixed up manual whitelisting and AA subscription. #4386 works correctly even in 1.5.1 when theatlantic.com is whitelisted manually.""

@mario the above story was implemented but the testing website theatlantic.com per #4386 keeps displaying the ad prevention warning - still not whitelisted. Please provide here (or get someone to provide) the relevant lines from base filterlist and AA exceptions override which is supposed to lead to this whitelisting. We will then verify subscription downloads to find out whether it's still a problem in logic or in the infrastructure.

Last edited 8 months ago by pavelz (previous) (diff)

comment:3 Changed 8 months ago by pavelz

  • Keywords blocked removed

comment:4 Changed 7 months ago by pavelz

  • Resolution set to fixed
  • Status changed from new to closed

comment:5 Changed 5 months ago by mario

  • Milestone set to Adblock-Browser-for-iOS-next

comment:6 Changed 5 months ago by scheer

  • Tester changed from Unknown to Scheer
  • Verified working set
  • #4372 - Prevent advanced WebSocket circumvention where our content scripts can't run
    • This change only applies to Chrome and Opera API’s. This was not testable on ABB iOS.
  • #4448 - Use 'websocket' type for WebSocket connections
    • This change only applies to Chrome and Opera API’s. In addition to this, manual filters are not possible in ABB iOS.

#4295 - Update adblockplusui dependency to revision 53626d2055a6

  1. #3952 - Fix whitespaces in Python code for compliance with PEP-8
    • A change that does not reflect a regression test in ABB iOS.
  2. #3999 - Response to filters.get/cssproperties message should contain filter text
    • A change that does not reflect a regression test in ABB iOS.
  3. #4201 - CSS property filter still applied when ABP is disabled everywhere
    • Website whitelisting is available in ABB iOS, but custom filters are not. Due to this, this issue was not regressed.
  4. #4297 - "filterlistsReinitialized" test parameter broken
    • No First-Run page is displayed in ABB iOS.
  • #4364 - Drop support for Chrome 29-40 and remove legacy code
    • This is a change to Chrome supported versions that do not affect ABB iOS.
  • #4466 - Update adblockpluscore dependency, replace rsa.js with rsa module
    • This is a change that applies to Chrome, Opera and Safari.
  • #4351 - Video ads on YouTube are not blocked using Safari 6 (Flash)
    • Although this was based around Safari 6 (Flash), I had already tested against Youtube for pre-roll ads and did not experience any.
  • #4477 - Update adblockpluscore dependency and getSelectorsForDomain usage
    • A change that does not reflect a regression test in ABB iOS

ABB 1.5.2-devbuild (1409)
iPhone 6s Plus
iOS 10.2

Note: See TracTickets for help on using tickets.