Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#4562 closed defect (rejected)

State of last subscription modification it not restored after restart

Reported by: Ross Assignee:
Priority: Unknown Milestone:
Module: Platform Keywords:
Cc: oleksandr, sebastian, Ross Blocked By:
Blocking: Platform: Edge
Ready: no Confidential: no
Tester: Unknown Verified working: no
Review URL(s):

Description

Environment

ABP Edge 0.9.9
Edge 38.14393.0.0 / Windows 10

How to reproduce

  1. Install ABP for Edge.
  2. Add all of the custom subscriptions from the first run page.
  3. Open the ABP Options page.
  4. Enable the Adblock Warning Removal List subscription.
  5. Restart edge.
  6. Observe the Adblock Warning Removal List is disabled again.

Observed behaviour

The state of the Adblock Warning Removal List is not restored (see attached video).

Expected behaviour

The state of the Adblock Warning Removal List (and all others) to be restored to the values set by the user before restart.

Notes

Reproduced 4/6 times using the steps above. Could reproduce using when disabling a different list at Step 4 (such as one just added from the first run page like malware). If two subscriptions are disabled, only one is restored (second video).

Could not reproduce when just adding one list from the first run page (tried a couple of times).

Attachments (2)

subscriptionstate-edge.mp4 (4.2 MB) - added by Ross 3 years ago.
subscriptionstate-edge2.mp4 (3.5 MB) - added by Ross 3 years ago.

Download all attachments as: .zip

Change History (9)

Changed 3 years ago by Ross

Changed 3 years ago by Ross

comment:1 Changed 3 years ago by oleksandr

I cannot reproduce it 6/6. Could it be that you were closing Edge before the changes have been saved? (It does take more time to save the lists with more filters being present especially on slower hardware). Can you reproduce it with a more substantial delay?

comment:2 Changed 3 years ago by oleksandr

  • Cc Ross added

comment:3 Changed 3 years ago by Ross

It does not seem reproducible with a longer delay (8-10s). Is reproducible with a relatively short delay (1-3s). Not a major issue as most users won't close the browser after changing settings so quickly.

Last edited 3 years ago by Ross (previous) (diff)

comment:4 Changed 3 years ago by sebastian

  • Resolution set to rejected
  • Status changed from new to closed

Also I'm not sure whether we can do something about it on our end anyway if Edge terminates before the data get a chance to be written. Closing the issue, for now, and moving forward with the release.

comment:5 Changed 3 years ago by mapx

ABP could keep the settings (what lists are enabled, other parameters) separate from the filters.
Even if someone closes quickly edge at least the lists of lists will be saved (in the settings file / sql container).

On start, it should check if the 2 entities are coherent (in case there arent: the complete filters list will be regenerated).

Version 0, edited 3 years ago by mapx (next)

comment:6 Changed 3 years ago by sebastian

If it is IndexedDB, or our code serializing the filter data, being slow here, that could help. But if other means of storage will have a similar delay (not unlikely), this wouldn't change anything.

Either way, this doesn't seem to be a new regression, neither is it established how likely this issue will be noticed by users. Note that Ross presumably used a fairly slow virtual machine, and closing the browser just after changing your filter settings isn't a particular common use case either.

Last edited 3 years ago by sebastian (previous) (diff)

comment:7 Changed 3 years ago by Ross

Yes it was on a fairly slow virtual machine. I do access to a proper non-VM Win 10 machine sometimes so I'll be sure to try this out again there.

Note: See TracTickets for help on using tickets.