Opened 3 years ago

Closed 2 years ago

#4570 closed defect (rejected)

ABP 0.9.9 loses custom filters when clear "cookies and saved website data"

Reported by: mapx Assignee:
Priority: Unknown Milestone:
Module: Unknown Keywords:
Cc: oleksandr, sebastian, freak.vulgar, Ross Blocked By:
Blocking: Platform: Edge
Ready: no Confidential: no
Tester: Unknown Verified working: no
Review URL(s):

Description

Environment

w 10
edge browser
ABP 0.9.9, easylist

How to reproduce

  • add a custom filter
  • go to edge settings, clear section, "choose what to clear", select "cookies and saved website data"

Close / open edge ==> the custom filter is gone.

Is this an expected behaviour ?
(reported in forum, I can reproduce it)

Change History (4)

comment:1 Changed 3 years ago by freak.vulgar

these comments from Adblock forum, I have just registered here:

Adblock can't keep the "Filter Subscriptions" if the checkbox "Cookies and saved website data" is checked. I checked all the checkboxes excluding "cookies", and after the "close/open" operation, all subscriptions were on their place (remained).
so, maybe the problem is on the "Cookies and..." checkbox side. It happens only when you clear your browser data with checkbox "Cookies.." is checked. In my case, I use the "Always clear this when I close the browser" switch. If you don't clear data manually or don't use "clear when close the browser" the subscription will be remained.

Windows 10 Anniversary Update Version 1607 build 14393.351
Microsoft Edge 38.14393.0.0
Microsoft EdgeHTML 14.14393

comment:2 Changed 3 years ago by mapx

  • Cc freak.vulgar added

comment:3 Changed 2 years ago by Ross

Reproduced. This also causes the First Run Page to appear on Edge restart with the "All your filter lists were removed" warning.

ABP 0.9.11.1849
Edge 40 / Windows 10

comment:4 Changed 2 years ago by sebastian

  • Cc Ross added
  • Resolution set to rejected
  • Status changed from new to closed

This is a known limitation of IndexedDB on Microsoft Edge. However, the alternative, storage.local causes even worse issues at the moment, as it is ridiculous slow. Therefore there is nothing we can do about this until Microsoft improves the storage mechanisms in future versions of Microsoft Edge.

Note: See TracTickets for help on using tickets.