Opened 3 years ago

Closed 3 years ago

#4571 closed defect (invalid)

Whitelisting rules no longer work in Edge

Reported by: scottlow Assignee:
Priority: Unknown Milestone:
Module: Unknown Keywords:
Cc: oleksandr Blocked By:
Blocking: Platform: Edge
Ready: no Confidential: no
Tester: Unknown Verified working: no
Review URL(s):

Description

Environment

Windows 10 Insider Preview

How to reproduce

  1. Install Adblock Plus 0.9.9.0
  2. Add a whitelist filter for a domain in the options page

...

Observed behaviour

The domain is not whitelisted

Expected behaviour

The domain should be whitelisted

Change History (5)

comment:1 Changed 3 years ago by Ross

Whitelisting appears to be working in 0.9.9 on the sites I tested. Is there a specific site/steps that break whitelisting?

comment:2 Changed 3 years ago by oleksandr

  • Cc oleksandr added

comment:3 Changed 3 years ago by scottlow

Here are my full repro steps:

  1. Navigate to http://simple-adblock.com/faq/testing-your-adblocker/ and verify that both squares are showing up as green (ad blocking is working)
  2. Add "http://simple-adblock.com/" to whitelisted domains (I tried http://simple-adblock.com/faq/testing-your-adblocker/ as well with the same results)
  3. Refresh the page

Notice that both squares are still green (meaning that ad blocking is still working). I notice that this reproduces on Chrome as well. Is it possible I'm setting an incorrect rule?

comment:4 Changed 3 years ago by oleksandr

You would add whitelisting domains without the protocol part. Have you tried just simple-adblock.com? That works for me.

comment:5 Changed 3 years ago by scottlow

  • Resolution set to invalid
  • Status changed from new to closed

Ah, that worked. That's what I get for not reading the directions on the "Whitelist domain" page :). Thanks!

Note: See TracTickets for help on using tickets.