Opened 14 months ago

Closed 13 months ago

Last modified 9 months ago

#4577 closed change (fixed)

Remove Safari specific code and files from the master branch

Reported by: kzar Assignee: kzar
Priority: P3 Milestone: Adblock-Plus-1.13-for-Chrome-Opera
Module: Platform Keywords:
Cc: sebastian Blocked By: #4551
Blocking: Platform: Safari
Ready: yes Confidential: no
Tester: Ross Verified working: yes
Review URL(s):

https://codereview.adblockplus.org/29363445/

Description (last modified by kzar)

Background

Once the work has been done to allow Safari to be built from the safari bookmark we will need to begin stripping out Safari specific stuff from master.

What to change

Remove all Safari specific files, including metadata.safari and the Safari platform code under ext/safari.

Hints for testers

Check that nothing broke in both a recent and old version of Chrome. (e.g. both 55 and 49). Please be quite thorough since we removed a lot of files and code. Some things to test include:

  • Adblocking and whitelisting.
  • Icon animations, especially with a whitelisted page that results in the Adblock Plus icon being grey.
  • The options page and popup window. Check that they both look and function the same as before.
  • The "block element" tool.
  • WebSocket blocking (See #1727).

Change History (7)

comment:1 Changed 13 months ago by kzar

  • Owner set to kzar
  • Priority changed from Unknown to P3
  • Ready set

comment:2 Changed 13 months ago by kzar

  • Review URL(s) modified (diff)
  • Status changed from new to reviewing

comment:3 Changed 13 months ago by kzar

  • Description modified (diff)

comment:4 Changed 13 months ago by abpbot

A commit referencing this issue has landed:
Issue 4577 - Remove Safari support

comment:5 Changed 13 months ago by kzar

  • Milestone set to Adblock-Plus-for-Chrome-Opera-next
  • Resolution set to fixed
  • Status changed from reviewing to closed

comment:6 Changed 12 months ago by kzar

  • Description modified (diff)

comment:7 Changed 9 months ago by Ross

  • Tester changed from Unknown to Ross
  • Verified working set

Done and hasn't caused any obvious regressions.

ABP 1.12.4.1739
Chrome 49 / 56 / Windows 10
Chrome 56 / OS X 10.12
Chrome 56 / Ubuntu 16.04
Opera 37 / 41 / Windows 7
Safari 10 / OS X 10.12

Note: See TracTickets for help on using tickets.