Opened 11 months ago

Closed 11 months ago

Last modified 10 months ago

#4587 closed defect (fixed)

Blockable items list calls reloadDisabledFilters() unnecessarily often

Reported by: trev Assignee: trev
Priority: P2 Milestone: Adblock-Plus-2.8.2-for-Firefox
Module: Adblock-Plus-for-Firefox Keywords:
Cc: Blocked By:
Blocking: Platform: Unknown / Cross platform
Ready: yes Confidential: no
Tester: Ross Verified working: yes
Review URL(s):

https://codereview.adblockplus.org/29361127/

Description (last modified by trev)

Environment

Firefox 52.0a1 (2016-10-28 nightly) - multiprocess enabled
Adblock Plus 2.8.1.4222-beta
macOS 10.12

How to reproduce

  1. Press Ctrl/Cmd-Shift-V to open Blockable items list.
  2. Load http://heise.de/

Observed behaviour

The page loads considerably slower than with Blockable items list closed.

Expected behaviour

There shouldn't be a significant slowdown.

Background

Profiling shows that the blockable items list keeps calling reloadDisabledFilters() function. This is supposed to happen when filters change, it is currently being triggered by filter hits as well however.

Hints for testers

This change affects Blockable items list displaying disabled filters, the functionality should stay unchanged. If a disabled filter would normally match an allowed request, the Blockable items list should indicate that - and it should consider filters that were disabled while the list is already open. This functionality ignores subscriptions and filter groups that are completely disabled, so changes here should be reflected properly as well.

Change History (6)

comment:1 Changed 11 months ago by trev

  • Description modified (diff)
  • Review URL(s) modified (diff)
  • Status changed from new to reviewing

comment:3 Changed 11 months ago by trev

  • Milestone set to Adblock-Plus-for-Firefox-next
  • Resolution set to fixed
  • Status changed from reviewing to closed

comment:4 Changed 10 months ago by Ross

The slowdown feels fixed.

I'm not sure on the behaviour of filters that have been disabled from the blockable items list? For example, on Heise, if I disable the .promoad filter, it is completely removed from the blockable items list and does not reappear, say, for the user to reenable, is that intended?

ABP 2.8.1.4230-beta
Firefox Nightly 53.0a1 (2017-11-17) / OS X 10.10

comment:5 Changed 10 months ago by trev

Yes, disabled element hiding filters cannot be displayed, it only works for blocking filters.

comment:6 Changed 10 months ago by Ross

  • Tester changed from Unknown to Ross
  • Verified working set

Okay, thank you for the clarification.

ABP 2.8.1.4231-beta
Firefox 38 / 49 / Windows 7

Note: See TracTickets for help on using tickets.