#4588 closed defect (fixed)

Element Hiding Helper: "View source" command doesn't show text nodes

Reported by: trev Assignee: trev
Priority: P2 Milestone: Element-Hiding-Helper-1.4
Module: Extensions-for-Adblock-Plus Keywords:
Cc: DrainElephant Blocked By:
Blocking: Platform: Unknown / Cross platform
Ready: yes Confidential: no
Tester: Unknown Verified working: no
Review URL(s):

https://codereview.adblockplus.org/29361130/

Description

Environment

Element Hiding Helper 1.3.10.545

How to reproduce

  1. Select a text paragraph.
  2. Press V to view source in tooltip.

Observed behaviour

Only <p /> is displayed in tooltip, not the text content.

Expected behaviour

The tooltip should display the entire HTML code, including text.

Background

This regressed when Element Hiding Helper was turned into a restartless extension in January 2012 - an unrelated change made the loop skip non-element children.

Change History (5)

comment:1 Changed 13 months ago by trev

  • Review URL(s) modified (diff)
  • Status changed from new to reviewing

comment:2 Changed 13 months ago by DrainElephant

Thanks for this.

(Is there a[nother] way to cc myself on a ticket [other than replying to it]?)

comment:3 Changed 13 months ago by trev

  • Cc DrainElephant added

Replying to an issue won't get you on the Cc list, you actually need to change the Cc field.

comment:4 Changed 13 months ago by abpbot

A commit referencing this issue has landed:
Issue 4588 - "View source" command doesn't show text nodes

comment:5 Changed 13 months ago by trev

  • Milestone set to Element-Hiding-Helper-next
  • Resolution set to fixed
  • Status changed from reviewing to closed
Note: See TracTickets for help on using tickets.