Opened 9 months ago

Closed 5 months ago

#4598 closed defect (fixed)

Scripts that supposed to be blocked aren't

Reported by: arthur Assignee: kzar
Priority: P2 Milestone: Adblock-Plus-1.13-for-Chrome-Opera
Module: Platform Keywords:
Cc: sebastian, kzar, innerself, mapx, rhana@… Blocked By: #4647
Blocking: Platform: Chrome
Ready: yes Confidential: no
Tester: Unknown Verified working: no
Review URL(s):

https://codereview.adblockplus.org/29362605/

Description (last modified by kzar)

Environment

Win 10 Pro
Chrome 54.0.2840.87 m (64-bit)
ABP 1.12.4 and 1.12.4.1672
EasyList
Custom filter: @@||securepubads.g.doubleclick.net/gpt/pubads_impl_110.js$domain=allestörungen.de

How to reproduce

  1. Create a new tab and open the developer tools for it. Switch to the Network tab.
  2. Browse to http://allestörungen.de/stoerung/unity-media/karte/ in the new tab.
  3. Type securepubads.g.doubleclick.net into the Filter box at the top left of the developer tools Network tab.

Observed behaviour

The ads?gdfrp_req=1&correlator=... requests aren't blocked. They also aren't visible in the Adblock Plus developer tools tab.

Expected behaviour

Those requests should be blocked and listed as such in the Adblock Plus tab.

Change History (25)

comment:1 Changed 9 months ago by mapx

  • Cc mapx added

comment:2 Changed 9 months ago by mapx

reproducible also:

  • use only easylist
  • add this filter

@@||partner.googleadservices.com/gpt/pubads_impl_104.js$domain=hipertextual.com

securepubads.g.doubleclick.net wont be blocked

comment:3 Changed 9 months ago by mapx

same behaviour here:
http://allestörungen.de/stoerung/unity-media/karte/

add
@@||partner.googleadservices.com/gpt/pubads_impl_104.js$domain=allestörungen.de

securepubads is not blocked

comment:4 Changed 8 months ago by kzar

  • Owner set to kzar

Have you guys tried reproducing this on Firefox or Safari?

comment:5 Changed 8 months ago by mapx

securepubads correctly blocked in abp for firefox

comment:6 Changed 8 months ago by arthur

They seem to be blocked in Safari 10.0 with ABP 1.12.4.1681.

Last edited 8 months ago by arthur (previous) (diff)

comment:7 Changed 8 months ago by kzar

I'm having difficulty reproducing this. I don't see any requests to securepubads.g.doubleclick.net being made, allowed or blocked by either site. (I also tried changing the filter since I noticed the script is now pubads_impl_105.js.)

What did you mean by "the search field" in the steps to reproduce, the URL bar, search field in the Adblock Plus devtools pane or something else?

comment:8 Changed 8 months ago by mapx

  • search field in the network tab
  • however, I tested again both sites, now the securepubads are blocked (chrome Version 55.0.2883.44 beta (64-bit), ABP 1.12.4.1682) and visible also in dev ABP panel. Weird ..
Last edited 8 months ago by mapx (previous) (diff)

comment:9 Changed 8 months ago by arthur

  • Description modified (diff)

Sorry for not being very clear, udpated the steps to reproduce.

Still happening for me with Chrome Beta 55.0.2883.44 and ABP 1.12.4.1682.

comment:10 Changed 8 months ago by kzar

Thanks for clarifying but still struggling to reproduce this. When I type "securepubads.g.doubleclick.net" into the search field for the Network request tab I don't get any matches for either website. Even when I disable all Adblock Plus filters.

comment:12 Changed 8 months ago by kzar

  • Component changed from Unknown to Platform
  • Description modified (diff)
  • Priority changed from Unknown to P2
  • Ready set

Aha finally got it, I was using the search feature (C-f) instead of the filter box at the top left. (Kind of confusing UI since for the profiler you hit C-f to do the same thing.)

comment:13 Changed 8 months ago by kzar

  • Blocked By 4647 added

The request is being made inside an iframe which looks something like this:

<iframe id="google_ads_iframe_/11637228/allestoerungen.de-textad_0__hidden__"
        title="" name="google_ads_iframe_/11637228/allestoerungen.de-textad_0__hidden__"
        width="0" height="0" scrolling="no" marginwidth="0" marginheight="0"
        frameborder="0" srcdoc=""
        style="border: 0px; vertical-align: bottom; visibility: hidden; display: none;">
  <html>
    <head>
      <script type="text/javascript">
        function callbackProxy(adContents) {
          window.parent.googletag.impl.pubads.setAdContentsBySlotForAsync(adContents, 1);
        }
      </script>
      <script src="https://securepubads.g.doubleclick.net/gampad/ads?gdfp_req=1&amp;correlator=..."></script>
    </head>
    <body marginwidth="0" marginheight="0">
    </body>
  </html>
</iframe>
  1. Firstly the iframe often performs the request before its onCommitted event was fired which triggers an exception (see #4647).

2. Secondly the frame URL of about:srcdoc seems to be confusing our logic somehow in a way that I don't yet understand.

Continuing to investigate...

Last edited 8 months ago by kzar (previous) (diff)

comment:14 Changed 8 months ago by kzar

Nope, looks like this has the same cause as #4647. I was just mistaken since my fix had a typo...

comment:15 Changed 8 months ago by kzar

  • Review URL(s) modified (diff)
  • Status changed from new to reviewing

comment:16 Changed 8 months ago by kzar

  • Review URL(s) modified (diff)

comment:17 Changed 8 months ago by kzar

  • Cc rhana@… added

comment:18 Changed 6 months ago by sebastian

  • Milestone set to Adblock-Plus-for-Chrome-Opera-next

comment:19 Changed 6 months ago by kzar

  • Description modified (diff)

(Still waiting for codereview, but just updated the test filter since the page has changed a little since the issue was last updated.)

comment:20 Changed 5 months ago by kzar

  • Description modified (diff)

comment:21 Changed 5 months ago by kzar

I wanted to check my modified fix still works but I'm having trouble reproducing the problem at all now. Can anyone else still reproduce this / know another site where this still happens?

comment:22 Changed 5 months ago by arthur

I also couldn't reproduce this anymore.

comment:23 Changed 5 months ago by kzar

Yea, I guess they updated their website. If anyone does find a new site that breaks in a similar way post a link here, it would be useful for testing.

comment:24 Changed 5 months ago by abpbot

A commit referencing this issue has landed:
Issue 4598,4599,4647,4804 - Work around onCommitted flaw

comment:25 Changed 5 months ago by kzar

  • Resolution set to fixed
  • Status changed from reviewing to closed
Note: See TracTickets for help on using tickets.