Opened on 11/03/2016 at 02:27:07 PM

Closed on 02/28/2017 at 12:52:49 PM

#4598 closed defect (fixed)

Scripts that supposed to be blocked aren't

Reported by: arthur Assignee: kzar
Priority: P2 Milestone: Adblock-Plus-1.13-for-Chrome-Opera
Module: Platform Keywords:
Cc: sebastian, kzar, innerself, mapx, Blocked By: #4647
Blocking: Platform: Chrome
Ready: yes Confidential: no
Tester: Unknown Verified working: no
Review URL(s):

Description (last modified by kzar)


Win 10 Pro
Chrome 54.0.2840.87 m (64-bit)
ABP 1.12.4 and
Custom filter: @@||$domain=allestö

How to reproduce

  1. Create a new tab and open the developer tools for it. Switch to the Network tab.
  2. Browse to http://allestö in the new tab.
  3. Type into the Filter box at the top left of the developer tools Network tab.

Observed behaviour

The ads?gdfrp_req=1&correlator=... requests aren't blocked. They also aren't visible in the Adblock Plus developer tools tab.

Expected behaviour

Those requests should be blocked and listed as such in the Adblock Plus tab.

Attachments (0)

Change History (25)

comment:1 Changed on 11/03/2016 at 07:39:24 PM by mapx

  • Cc mapx added

comment:2 Changed on 11/06/2016 at 10:25:15 AM by mapx

reproducible also:

  • use only easylist
  • add this filter

@@||$ wont be blocked

comment:3 Changed on 11/06/2016 at 10:41:24 AM by mapx

same behaviour here:


securepubads is not blocked

comment:4 Changed on 11/09/2016 at 10:10:56 AM by kzar

  • Owner set to kzar

Have you guys tried reproducing this on Firefox or Safari?

comment:5 Changed on 11/09/2016 at 10:15:32 AM by mapx

securepubads correctly blocked in abp for firefox

comment:6 Changed on 11/09/2016 at 10:39:55 AM by arthur

They seem to be blocked in Safari 10.0 with ABP

Last edited on 11/09/2016 at 10:40:47 AM by arthur

comment:7 Changed on 11/15/2016 at 10:49:56 AM by kzar

I'm having difficulty reproducing this. I don't see any requests to being made, allowed or blocked by either site. (I also tried changing the filter since I noticed the script is now pubads_impl_105.js.)

What did you mean by "the search field" in the steps to reproduce, the URL bar, search field in the Adblock Plus devtools pane or something else?

comment:8 Changed on 11/15/2016 at 11:04:16 AM by mapx

  • search field in the network tab
  • however, I tested again both sites, now the securepubads are blocked (chrome Version 55.0.2883.44 beta (64-bit), ABP and visible also in dev ABP panel. Weird ..
Last edited on 11/15/2016 at 11:04:44 AM by mapx

comment:9 Changed on 11/15/2016 at 11:12:52 AM by arthur

  • Description modified (diff)

Sorry for not being very clear, udpated the steps to reproduce.

Still happening for me with Chrome Beta 55.0.2883.44 and ABP

comment:10 Changed on 11/15/2016 at 12:04:25 PM by kzar

Thanks for clarifying but still struggling to reproduce this. When I type "" into the search field for the Network request tab I don't get any matches for either website. Even when I disable all Adblock Plus filters.

comment:11 Changed on 11/15/2016 at 01:28:44 PM by arthur

comment:12 Changed on 11/15/2016 at 02:11:18 PM by kzar

  • Component changed from Unknown to Platform
  • Description modified (diff)
  • Priority changed from Unknown to P2
  • Ready set

Aha finally got it, I was using the search feature (C-f) instead of the filter box at the top left. (Kind of confusing UI since for the profiler you hit C-f to do the same thing.)

comment:13 Changed on 11/15/2016 at 03:53:35 PM by kzar

  • Blocked By 4647 added

The request is being made inside an iframe which looks something like this:

<iframe id="google_ads_iframe_/11637228/"
        title="" name="google_ads_iframe_/11637228/"
        width="0" height="0" scrolling="no" marginwidth="0" marginheight="0"
        frameborder="0" srcdoc=""
        style="border: 0px; vertical-align: bottom; visibility: hidden; display: none;">
      <script type="text/javascript">
        function callbackProxy(adContents) {
          window.parent.googletag.impl.pubads.setAdContentsBySlotForAsync(adContents, 1);
      <script src=";correlator=..."></script>
    <body marginwidth="0" marginheight="0">
  1. Firstly the iframe often performs the request before its onCommitted event was fired which triggers an exception (see #4647).

2. Secondly the frame URL of about:srcdoc seems to be confusing our logic somehow in a way that I don't yet understand.

Continuing to investigate...

Last edited on 11/15/2016 at 04:01:29 PM by kzar

comment:14 Changed on 11/15/2016 at 04:01:06 PM by kzar

Nope, looks like this has the same cause as #4647. I was just mistaken since my fix had a typo...

comment:15 Changed on 11/15/2016 at 04:14:28 PM by kzar

  • Review URL(s) modified (diff)
  • Status changed from new to reviewing

comment:16 Changed on 11/16/2016 at 06:32:16 PM by kzar

  • Review URL(s) modified (diff)

comment:17 Changed on 11/17/2016 at 04:05:46 PM by kzar

  • Cc added

comment:18 Changed on 01/07/2017 at 10:35:27 AM by sebastian

  • Milestone set to Adblock-Plus-for-Chrome-Opera-next

comment:19 Changed on 01/23/2017 at 09:37:56 AM by kzar

  • Description modified (diff)

(Still waiting for codereview, but just updated the test filter since the page has changed a little since the issue was last updated.)

comment:20 Changed on 02/15/2017 at 06:03:01 AM by kzar

  • Description modified (diff)

comment:21 Changed on 02/15/2017 at 06:10:43 AM by kzar

I wanted to check my modified fix still works but I'm having trouble reproducing the problem at all now. Can anyone else still reproduce this / know another site where this still happens?

comment:22 Changed on 02/15/2017 at 09:51:49 AM by arthur

I also couldn't reproduce this anymore.

comment:23 Changed on 02/15/2017 at 09:56:30 AM by kzar

Yea, I guess they updated their website. If anyone does find a new site that breaks in a similar way post a link here, it would be useful for testing.

comment:24 Changed on 02/28/2017 at 12:27:45 PM by abpbot

A commit referencing this issue has landed:
Issue 4598,4599,4647,4804 - Work around onCommitted flaw

comment:25 Changed on 02/28/2017 at 12:52:49 PM by kzar

  • Resolution set to fixed
  • Status changed from reviewing to closed

Add Comment

Modify Ticket

Change Properties
as closed .
The resolution will be deleted. Next status will be 'reopened'.
to The owner will be changed from kzar.
Note: See TracTickets for help on using tickets.