Opened 3 years ago

Closed 3 years ago

#4601 closed defect (worksforme)

White ad spaces are not collapsed in Yahoo Articles on AdblockWebView

Reported by: scheer Assignee:
Priority: Unknown Milestone:
Module: Libadblockplus-Android Keywords:
Cc: Anton Blocked By:
Blocking: Platform: Android
Ready: no Confidential: no
Tester: Scheer Verified working: yes
Review URL(s):

Description (last modified by scheer)

Ads are blocked correctly within articles on Yahoo.com, but the white ad spaces are still left behind. These should be collapsed as is also done in ABB Android.

Environment

ABP for Lightning Browser (95)
Galaxy S7
Android 6.0.1

How to reproduce

  1. Visit Yahoo.com and select an article
  2. Scroll through the article

Observed behaviour

White ad spaces remain.

Expected behaviour

White ad spaces should be collapsed.

Attachments (17)

WebView Yahoo. ABB Android.txt (74.5 KB) - added by scheer 3 years ago.
WebView Yahoo. Lightning (95).txt (190.6 KB) - added by scheer 3 years ago.
ABB Android No White Spaces.png (303.8 KB) - added by scheer 3 years ago.
Lightning Browser White Spaces.png (208.9 KB) - added by scheer 3 years ago.
device-2016-11-07-170403.png (258.4 KB) - added by asmirnov 3 years ago.
1: abp disabled - we can see ads
device-2016-11-07-170302.png (223.8 KB) - added by asmirnov 3 years ago.
1: abp enabled - we can see NO ads and NO whitespaces
device-2016-11-07-165944.png (681.7 KB) - added by asmirnov 3 years ago.
2: abp disabled - we can see ads
device-2016-11-07-165917.png (1.1 MB) - added by asmirnov 3 years ago.
1: abp enabled - we can see no ads, no whitespaces
device-2016-11-07-165835.png (219.2 KB) - added by asmirnov 3 years ago.
3: abp disabled - we can see ads
device-2016-11-07-165737.png (1.6 MB) - added by asmirnov 3 years ago.
3: abp enabled - we can see no ads, no whitespaces
Снимок экрана 2016-11-07 в 17.56.22.png (523.4 KB) - added by asmirnov 3 years ago.
yahoo js
1-enabled.png (410.0 KB) - added by asmirnov 3 years ago.
1-disabled.png (313.2 KB) - added by asmirnov 3 years ago.
2-disabled.png (403.2 KB) - added by asmirnov 3 years ago.
2-enabled.png (258.0 KB) - added by asmirnov 3 years ago.
3-disabled.png (489.5 KB) - added by asmirnov 3 years ago.
3-enabled.png (220.1 KB) - added by asmirnov 3 years ago.

Download all attachments as: .zip

Change History (26)

Changed 3 years ago by scheer

Changed 3 years ago by scheer

Changed 3 years ago by scheer

Changed 3 years ago by scheer

comment:1 Changed 3 years ago by scheer

  • Description modified (diff)

comment:2 Changed 3 years ago by asmirnov

According to the log attached, CSS selectors list was requested from FilterEngine and applied:

// requesting CSS selectors from Filter Engine
11-04 09:05:09.679 10039-10184/acr.browser.barebones D/AdblockWebView: Requesting elemhide selectors from AdblockEngine for https://de.yahoo.com/?p=us in Thread[Thread-558,5,main]
...
11-04 09:05:09.969 10039-10184/acr.browser.barebones D/AdblockWebView: Finished requesting elemhide selectors, got 17567 in Thread[Thread-558,5,main]

// creating CSS rules dynamically
11-04 09:05:10.829 10039-10039/acr.browser.barebones D/AdblockWebView: JS: level=LOG, message="parsed selectors: 17567", sourceId="", line=15
422	11-04 09:05:10.829 10039-10039/acr.browser.barebones I/chromium: [INFO:CONSOLE(15)] "parsed selectors: 17567", source:  (15)
423	11-04 09:05:11.219 10039-10039/acr.browser.barebones D/AdblockWebView: JS: level=LOG, message="finished injecting css rules", sourceId="", line=31
424	11-04 09:05:11.219 10039-10039/acr.browser.barebones I/chromium: [INFO:CONSOLE(31)] "finished injecting css rules", source:  (31)
425	11-04 09:05:11.219 10039-10183/acr.browser.barebones D/AdblockWebView: Scheduled 'allow drawing' invocation in 200 ms

comment:3 Changed 3 years ago by asmirnov

Unfortunately i was unable to reproduce it (see attached files)

Changed 3 years ago by asmirnov

1: abp disabled - we can see ads

Changed 3 years ago by asmirnov

1: abp enabled - we can see NO ads and NO whitespaces

Changed 3 years ago by asmirnov

2: abp disabled - we can see ads

Changed 3 years ago by asmirnov

1: abp enabled - we can see no ads, no whitespaces

Changed 3 years ago by asmirnov

3: abp disabled - we can see ads

Changed 3 years ago by asmirnov

3: abp enabled - we can see no ads, no whitespaces

comment:4 Changed 3 years ago by scheer

I am still able to reproduce this 100% on all articles on yahoo.com. Please note, as stated above, the device used was a Galaxy S7 with Easylist enabled only and no AA.

comment:5 Changed 3 years ago by asmirnov

I can reproduce it with just "easylist" subscription, but can't with "ru+easylist", continue investigation..

comment:6 Changed 3 years ago by asmirnov

for some reason "onPageStarted" is not fired. It means that it's not regular HTML link but JS is working.

Changed 3 years ago by asmirnov

yahoo js

Changed 3 years ago by asmirnov

Changed 3 years ago by asmirnov

Changed 3 years ago by asmirnov

Changed 3 years ago by asmirnov

Changed 3 years ago by asmirnov

Changed 3 years ago by asmirnov

comment:7 Changed 3 years ago by asmirnov

i can't reproduce it any more.. uploaded 3 screenshots: desktop with useragent="Mozilla/5.0 (Linux; Android 5.0; SM-N9005 Build/LRX21V; wv) AppleWebKit/537.36 (KHTML, like Gecko) Version/4.0 Chrome/54.0.2840.68 Mobile Safari/537.36" to have the same html as on mobile with ABP disabled and from mobile with AdblockWebView + ABP enabled (easylist)

comment:8 Changed 3 years ago by scheer

  • Tester changed from Unknown to Scheer
  • Verified working set
  • Also no longer occurs for me on AdblockWebView (97).

comment:9 Changed 3 years ago by scheer

  • Resolution set to worksforme
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.