Opened 3 years ago

Last modified 3 years ago

#4603 closed defect

Block element tool highlighting is broken by certain element hiding filters — at Version 7

Reported by: xqwztis Assignee:
Priority: P3 Milestone: Adblock-Plus-1.13-for-Chrome-Opera
Module: Platform Keywords:
Cc: kzar, sebastian, mapx, Lain_13 Blocked By:
Blocking: Platform: Chrome
Ready: yes Confidential: no
Tester: Ross Verified working: yes
Review URL(s):

https://codereview.adblockplus.org/29365526/

Description (last modified by kzar)

Environment

Chrome 54, Adblock Plus 1.12.4

No filter subscriptions at all, only this filter:

##div[class^="_"][style*="absolute"][style*="position"][style*="z-index"]

How to reproduce

  1. Browse to https://reddit.com (or any other website)
  2. Click the Adblock Plus icon and then "Block element".
  3. Roll the cursor over the page to select an element to block.

Observed behaviour

No elements are highlighted as the mouse passes over them.

Expected behaviour

Blockable elements should be highlighted yellow.

Change History (7)

comment:1 Changed 3 years ago by xqwztis

Environment

Extensions: 13

Apps: 5

Last edited 3 years ago by xqwztis (previous) (diff)

comment:2 Changed 3 years ago by mapx

  • Cc kzar sebastian mapx added

comment:3 Changed 3 years ago by mapx

well, all this strange behaviour is due to this filter in ruadlist:

##div[class^="_"][style*="absolute"][style*="position"][style*="z-index"]

whitelisting it all is ok.

The question is: how could a hiding filter provoke such weird behaviour ?

Last edited 3 years ago by mapx (previous) (diff)

comment:4 Changed 3 years ago by mapx

  • Cc Lain_13 added

comment:6 Changed 3 years ago by dimisa

comment:7 Changed 3 years ago by kzar

  • Component changed from Unknown to Platform
  • Description modified (diff)
  • Priority changed from Unknown to P3
  • Ready set
  • Summary changed from Adblock Plus doesn't highlight elements to be blocked (mac OS Sierra) to Block element tool highlighting is broken by certain element hiding filters

Can also reproduce this on Linux so seems unrelated to operating system.

Note: See TracTickets for help on using tickets.