Opened 3 years ago

Closed 3 years ago

#4608 closed defect (fixed)

Development build for Safari created from master bookmark

Reported by: kzar Assignee: jsonesen
Priority: P1 Milestone:
Module: Sitescripts Keywords:
Cc: jsonesen, trev, sebastian, kvas Blocked By:
Blocking: #4551 Platform: Unknown / Cross platform
Ready: yes Confidential: no
Tester: Unknown Verified working: no
Review URL(s):

https://codereview.adblockplus.org/29361779

Description (last modified by trev)

How to reproduce

Push a commit to the master bookmark of adblockpluschrome, leaving the safari bookmark alone.

Observed behaviour

The createNightlies scripts attempt to create a development build for Safari as well as Chrome and Opera.

Expected behaviour

Only Chrome and Opera builds should be created.

Analysis

There is a bug in the Configuration object, the revision property is defined as global - meaning common for all build configurations. Since there is no such global setting its value always defaults to "master".

What to change

The property needs to be defined with local=True parameter.

Change History (11)

comment:1 Changed 3 years ago by kzar

  • Owner set to kzar

comment:2 Changed 3 years ago by kzar

  • Owner kzar deleted

comment:3 Changed 3 years ago by trev

It seems that the configuration setting wasn't picked up for some reason, the Configuration object still gives me "master" even for Safari.

comment:4 Changed 3 years ago by trev

  • Description modified (diff)

comment:5 Changed 3 years ago by jsonesen

  • Review URL(s) modified (diff)

comment:6 Changed 3 years ago by jsonesen

  • Review URL(s) modified (diff)

comment:7 Changed 3 years ago by trev

  • Owner set to jsonesen

comment:8 Changed 3 years ago by trev

  • Status changed from new to reviewing

comment:9 Changed 3 years ago by sebastian

  • Ready set

comment:10 Changed 3 years ago by abpbot

A commit referencing this issue has landed:
Issue 4608 - Add local=True To Revision Property

comment:11 Changed 3 years ago by kzar

  • Resolution set to fixed
  • Status changed from reviewing to closed
Note: See TracTickets for help on using tickets.