Opened 3 years ago

Closed 3 years ago

#4611 closed defect (fixed)

Ads are displayed at the end of search results in Baidu.com AdblockWebView

Reported by: scheer Assignee:
Priority: Unknown Milestone:
Module: Libadblockplus-Android Keywords:
Cc: Anton Blocked By:
Blocking: Platform: Android
Ready: no Confidential: no
Tester: Scheer Verified working: yes
Review URL(s):

Description

Ads are shown at the end of search results on Baidu.com. Chinese Easylist is active and the behaviour is not reproducible in ABB for Android. I have attached both logs for ABB Android and AdblockWebView for comparison (As well as Screenshots.)

Environment

Adblock Webview (95) Lightning Browser
Galaxy S7
Android 6.0.1
Easylist China
AA Disabled

How to reproduce

  1. Enable Chinese Easylist from Settings
  2. Visit http://www.baidu.com
  3. Search for 'iPhone 6'
  4. Scroll to the bottom of the page
  5. Wait 3-4 seconds
  6. Move page up and down slightly so that bottom of page is still in view

Observed behaviour

After slightly moving the end of the page, search ads are displayed.

Expected behaviour

Search ads should not be displayed.

Attachments (8)

Screenshot_20161107-125824.png (355.8 KB) - added by scheer 3 years ago.
Screenshot_20161107-125801.png (285.5 KB) - added by scheer 3 years ago.
Baidu ABB Android.txt (231.0 KB) - added by scheer 3 years ago.
Baidu Lightning.txt (412.0 KB) - added by scheer 3 years ago.
Baidu New Log.txt (367.3 KB) - added by scheer 3 years ago.
style.png (525.5 KB) - added by asmirnov 3 years ago.
Снимок экрана 2016-11-14 в 13.53.55.png (509.0 KB) - added by asmirnov 3 years ago.
Ads is visible even with ABP Chrome (desktop + mobile useragent)
Снимок экрана 2016-11-14 в 14.12.02.png (512.9 KB) - added by asmirnov 3 years ago.
Blocked with user-defined rule

Download all attachments as: .zip

Change History (17)

Changed 3 years ago by scheer

Changed 3 years ago by scheer

Changed 3 years ago by scheer

Changed 3 years ago by scheer

comment:1 Changed 3 years ago by asmirnov

Can you explain how to understand if it's AA or just ads? Please check it with Lightning+ABP 97.

comment:2 Changed 3 years ago by scheer

  • Still occurs in AdblockWebView (97) Lightning Browser. New log attached.

广告 shows that it is an ad. The same ads and or the same formats are shown in Chrome with AA enabled. They also conform to our acceptable ads criteria which are found here: https://acceptableads.com/en/about/criteria.

Changed 3 years ago by scheer

comment:3 Changed 3 years ago by asmirnov

i've found the following:
1) ABB and AdblockWebView search results page looks absolutely in different ways
(i think i depends on request headers or agent string)
2) i've found XmlHttpRequest that loads ad banner at the bottom and it's not blocked by FilterEngine (passed contentType = XmlHttpREquest).

11-10 17:25:54.730 1397-1440 D/AdblockWebView: Header referrer for https://sp1.baidu.com/5b1ZeDe5KgQFm2e88IuM_a/mwb.gif?type=3&fm=view&data=%5B%7B%22type%22%3A%22heart%22%2C%22stay_time%22%3A21000%2C%22t%22%3A1478780754738%2C%22hist%22%3A%7B%22heart%22%3A4%2C%22w_scroll%22%3A3%7D%2C%22o%22%3A6%2C%22g%22%3A95769%7D%5D&qid=3082290899902600071&did=94622900baf3c17c9fd274f0c93336b0&q=Iphone%2B6&t=1478780754740 is https://m.baidu.com/from=844b/s?word=Iphone+6&sa=tb&ts=9074600&t_kt=0&ie=utf-8&rsv_t=18ab7PBpVE%252BFYeVmVISb20DvnJrEhzVSzMfbIAnPPUKAL9CMN1NQipYN5Q&rsv_pq=16623648087539186775&ss=100&rqlang=zh&rsv_sug4=2711&inputT=2688&oq=Iphone
11-10 17:25:54.750 1397-1440 W/AdblockWebView: Blocked loading https://sp1.baidu.com/5b1ZeDe5KgQFm2e88IuM_a/mwb.gif?type=3&fm=view&data=%5B%7B%22type%22%3A%22heart%22%2C%22stay_time%22%3A21000%2C%22t%22%3A1478780754738%2C%22hist%22%3A%7B%22heart%22%3A4%2C%22w_scroll%22%3A3%7D%2C%22o%22%3A6%2C%22g%22%3A95769%7D%5D&qid=3082290899902600071&did=94622900baf3c17c9fd274f0c93336b0&q=Iphone%2B6&t=1478780754740
11-10 17:26:01.220 1397-1440 D/AdblockWebView: Header referrer for https://m.baidu.com/from=844b/error is https://m.baidu.com/from=844b/s?word=Iphone+6&sa=tb&ts=9074600&t_kt=0&ie=utf-8&rsv_t=18ab7PBpVE%252BFYeVmVISb20DvnJrEhzVSzMfbIAnPPUKAL9CMN1NQipYN5Q&rsv_pq=16623648087539186775&ss=100&rqlang=zh&rsv_sug4=2711&inputT=2688&oq=Iphone
11-10 17:26:01.230 1397-1440 D/AdblockWebView: Allowed loading https://m.baidu.com/from=844b/error
11-10 17:26:02.460 1397-1440 D/AdblockWebView: Header referrer for https://m.baidu.com/rec?platform=wise&ms=1&rset=ad&word=Iphone+6&qid=3082290899902600071&rq=Iphone+6&from=844b&baiduid=81816C637AC733A77D8718263EC71FAF%3AFG%3D1&tn=&t=1478780762465&r=1956&adext=ppads%3D0%26imads%3D0%26adposnum%3D0%26qmdedupinfo%3D is https://m.baidu.com/from=844b/s?word=Iphone+6&sa=tb&ts=9074600&t_kt=0&ie=utf-8&rsv_t=18ab7PBpVE%252BFYeVmVISb20DvnJrEhzVSzMfbIAnPPUKAL9CMN1NQipYN5Q&rsv_pq=16623648087539186775&ss=100&rqlang=zh&rsv_sug4=2711&inputT=2688&oq=Iphone
11-10 17:26:02.470 1397-1440 D/AdblockWebView: Allowed loading https://m.baidu.com/rec?platform=wise&ms=1&rset=ad&word=Iphone+6&qid=3082290899902600071&rq=Iphone+6&from=844b&baiduid=81816C637AC733A77D8718263EC71FAF%3AFG%3D1&tn=&t=1478780762465&r=1956&adext=ppads%3D0%26imads%3D0%26adposnum%3D0%26qmdedupinfo%3D
11-10 17:26:03.420 1397-1440 D/AdblockWebView: Header referrer for https://m.baidu.com/from=844b/error is https://m.baidu.com/from=844b/s?word=Iphone+6&sa=tb&ts=9074600&t_kt=0&ie=utf-8&rsv_t=18ab7PBpVE%252BFYeVmVISb20DvnJrEhzVSzMfbIAnPPUKAL9CMN1NQipYN5Q&rsv_pq=16623648087539186775&ss=100&rqlang=zh&rsv_sug4=2711&inputT=2688&oq=Iphone
11-10 17:26:03.420 1397-1440 D/AdblockWebView: Allowed loading https://m.baidu.com/from=844b/error
11-10 17:26:03.540 1397-1440 D/AdblockWebView: Header referrer for https://sp0.baidu.com/-rU_dTmfKgQFm2e88IuM_a/w.gif?eid=110505_102065_415_111140_106323_110218_110782_107800_110606_110684_110395_110717_110672_110011_111169_109915_&baiduid=81816C637AC733A77D8718263EC71FAF&query=iphone%2B6&queryUtf8=iphone%2B6&searchid=2ac67f3e271d1387&osid=2&bwsid=4&wiseFrom=844b&ovlid=&netType=0&startHeight=2726&startTime=1478780762428&endHeight=2884&endTime=1478780763540&scrollTime=1112&scrollLen=158&scrollInter=1&scrolldirect=B&stayTime=20162&startViewZone=w_11_0.15%3Aw_11_1.00&endViewZone=w_11_0.98%3Aw_11_1.00&adpos=t_0_0.00&touchStart=227_172&touchEnd=236_133&action=scroll&top=0&wise=11&bottom=0&tag=ecom_wise_listen_n&rand=1478780763543 is https://m.baidu.com/from=844b/s?word=Iphone+6&sa=tb&ts=9074600&t_kt=0&ie=utf-8&rsv_t=18ab7PBpVE%252BFYeVmVISb20DvnJrEhzVSzMfbIAnPPUKAL9CMN1NQipYN5Q&rsv_pq=16623648087539186775&ss=100&rqlang=zh&rsv_sug4=2711&inputT=2688&oq=Iphone
11-10 17:26:03.550 1397-1440 W/AdblockWebView: Blocked loading https://sp0.baidu.com/-rU_dTmfKgQFm2e88IuM_a/w.gif?eid=110505_102065_415_111140_106323_110218_110782_107800_110606_110684_110395_110717_110672_110011_111169_109915_&baiduid=81816C637AC733A77D8718263EC71FAF&query=iphone%2B6&queryUtf8=iphone%2B6&searchid=2ac67f3e271d1387&osid=2&bwsid=4&wiseFrom=844b&ovlid=&netType=0&startHeight=2726&startTime=1478780762428&endHeight=2884&endTime=1478780763540&scrollTime=1112&scrollLen=158&scrollInter=1&scrolldirect=B&stayTime=20162&startViewZone=w_11_0.15%3Aw_11_1.00&endViewZone=w_11_0.98%3Aw_11_1.00&adpos=t_0_0.00&touchStart=227_172&touchEnd=236_133&action=scroll&top=0&wise=11&bottom=0&tag=ecom_wise_listen_n&rand=1478780763543
11-10 17:26:04.110 1397-1440 D/AdblockWebView: Header referrer for https://ss1.baidu.com/73N1bjeh1BF3odCf/it/u=2664486529,1345083220&fm=203&gp=0.jpg is https://m.baidu.com/from=844b/s?word=Iphone+6&sa=tb&ts=9074600&t_kt=0&ie=utf-8&rsv_t=18ab7PBpVE%252BFYeVmVISb20DvnJrEhzVSzMfbIAnPPUKAL9CMN1NQipYN5Q&rsv_pq=16623648087539186775&ss=100&rqlang=zh&rsv_sug4=2711&inputT=2688&oq=Iphone
11-10 17:26:04.120 1397-1440 D/AdblockWebView: Allowed loading https://ss1.baidu.com/73N1bjeh1BF3odCf/it/u=2664486529,1345083220&fm=203&gp=0.jpg
11-10 17:26:04.740 1397-1440 D/AdblockWebView: Header referrer for https://sp0.baidu.com/-rU_dTmfKgQFm2e88IuM_a/w.gif?eid=110505_102065_415_111140_106323_110218_110782_107800_110606_110684_110395_110717_110672_110011_111169_109915_&baiduid=81816C637AC733A77D8718263EC71FAF&query=iphone%2B6&queryUtf8=iphone%2B6&searchid=2ac67f3e271d1387&osid=2&bwsid=4&wiseFrom=844b&ovlid=&netType=0&asynsid=ec9c7a6f1c0acb70&startHeight=2884&startTime=1478780764124&endHeight=2723&endTime=1478780764733&scrollTime=609&scrollLen=-161&scrollInter=2&scrolldirect=T&stayTime=584&startViewZone=w_11_0.98%3Aw_11_1.00&endViewZone=w_11_0.14%3Ab_2_0.63&adpos=b_2_0.63&touchStart=232_99&touchEnd=221_211&action=scroll&top=0&wise=11&bottom=2&tag=ecom_wise_listen_n&rand=1478780764740 is https://m.baidu.com/from=844b/s?word=Iphone+6&sa=tb&ts=9074600&t_kt=0&ie=utf-8&rsv_t=18ab7PBpVE%252BFYeVmVISb20DvnJrEhzVSzMfbIAnPPUKAL9CMN1NQipYN5Q&rsv_pq=16623648087539186775&ss=100&rqlang=zh&rsv_sug4=2711&inputT=2688&oq=Iphone
11-10 17:26:04.760 1397-1440 W/AdblockWebView: Blocked loading https://sp0.baidu.com/-rU_dTmfKgQFm2e88IuM_a/w.gif?eid=110505_102065_415_111140_106323_110218_110782_107800_110606_110684_110395_110717_110672_110011_111169_109915_&baiduid=81816C637AC733A77D8718263EC71FAF&query=iphone%2B6&queryUtf8=iphone%2B6&searchid=2ac67f3e271d1387&osid=2&bwsid=4&wiseFrom=844b&ovlid=&netType=0&asynsid=ec9c7a6f1c0acb70&startHeight=2884&startTime=1478780764124&endHeight=2723&endTime=1478780764733&scrollTime=609&scrollLen=-161&scrollInter=2&scrolldirect=T&stayTime=584&startViewZone=w_11_0.98%3Aw_11_1.00&endViewZone=w_11_0.14%3Ab_2_0.63&adpos=b_2_0.63&touchStart=232_99&touchEnd=221_211&action=scroll&top=0&wise=11&bottom=2&tag=ecom_wise_listen_n&rand=1478780764740
11-10 17:26:06.040 1397-1440 D/AdblockWebView: Header referrer for https://sp0.baidu.com/-rU_dTmfKgQFm2e88IuM_a/w.gif?eid=110505_102065_415_111140_106323_110218_110782_107800_110606_110684_110395_110717_110672_110011_111169_109915_&baiduid=81816C637AC733A77D8718263EC71FAF&query=iphone%2B6&queryUtf8=iphone%2B6&searchid=2ac67f3e271d1387&osid=2&bwsid=4&wiseFrom=844b&ovlid=&netType=0&asynsid=ec9c7a6f1c0acb70&startHeight=2723&startTime=1478780764883&endHeight=2785&endTime=1478780766031&scrollTime=1148&scrollLen=62&scrollInter=3&scrolldirect=B&stayTime=150&startViewZone=w_11_0.14%3Ab_2_0.63&endViewZone=w_11_0.46%3Ab_2_1.00&adpos=b_2_1.00&touchStart=231_92&touchEnd=218_64&action=scroll&top=0&wise=11&bottom=2&tag=ecom_wise_listen_n&rand=1478780766033 is https://m.baidu.com/from=844b/s?word=Iphone+6&sa=tb&ts=9074600&t_kt=0&ie=utf-8&rsv_t=18ab7PBpVE%252BFYeVmVISb20DvnJrEhzVSzMfbIAnPPUKAL9CMN1NQipYN5Q&rsv_pq=16623648087539186775&ss=100&rqlang=zh&rsv_sug4=2711&inputT=2688&oq=Iphone
11-10 17:26:06.120 1397-1440 W/AdblockWebView: Blocked loading https://sp0.baidu.com/-rU_dTmfKgQFm2e88IuM_a/w.gif?eid=110505_102065_415_111140_106323_110218_110782_107800_110606_110684_110395_110717_110672_110011_111169_109915_&baiduid=81816C637AC733A77D8718263EC71FAF&query=iphone%2B6&queryUtf8=iphone%2B6&searchid=2ac67f3e271d1387&osid=2&bwsid=4&wiseFrom=844b&ovlid=&netType=0&asynsid=ec9c7a6f1c0acb70&startHeight=2723&startTime=1478780764883&endHeight=2785&endTime=1478780766031&scrollTime=1148&scrollLen=62&scrollInter=3&scrolldirect=B&stayTime=150&startViewZone=w_11_0.14%3Ab_2_0.63&endViewZone=w_11_0.46%3Ab_2_1.00&adpos=b_2_1.00&touchStart=231_92&touchEnd=218_64&action=scroll&top=0&wise=11&bottom=2&tag=ecom_wise_listen_n&rand=1478780766033


-- ads

11-10 17:26:02.460 1397-1440 D/AdblockWebView: Header referrer for https://m.baidu.com/rec?platform=wise&ms=1&rset=ad&word=Iphone+6&qid=3082290899902600071&rq=Iphone+6&from=844b&baiduid=81816C637AC733A77D8718263EC71FAF%3AFG%3D1&tn=&t=1478780762465&r=1956&adext=ppads%3D0%26imads%3D0%26adposnum%3D0%26qmdedupinfo%3D is https://m.baidu.com/from=844b/s?word=Iphone+6&sa=tb&ts=9074600&t_kt=0&ie=utf-8&rsv_t=18ab7PBpVE%252BFYeVmVISb20DvnJrEhzVSzMfbIAnPPUKAL9CMN1NQipYN5Q&rsv_pq=16623648087539186775&ss=100&rqlang=zh&rsv_sug4=2711&inputT=2688&oq=Iphone
11-10 17:26:02.470 1397-1440 D/AdblockWebView: Allowed loading https://m.baidu.com/rec?platform=wise&ms=1&rset=ad&word=Iphone+6&qid=3082290899902600071&rq=Iphone+6&from=844b&baiduid=81816C637AC733A77D8718263EC71FAF%3AFG%3D1&tn=&t=1478780762465&r=1956&adext=ppads%3D0%26imads%3D0%26adposnum%3D0%26qmdedupinfo%3D

--

comment:4 Changed 3 years ago by asmirnov

there is rule in chinese easylist and i've checked this selector to be returned by filter engine:

baidu.com##.ec_wise_ad

however it does not help and the ads is still visible

comment:5 Changed 3 years ago by asmirnov

it looks like it overrides css class display and visibility properties in element's attribute style - see attached style.png.

Last edited 3 years ago by asmirnov (previous) (diff)

Changed 3 years ago by asmirnov

Changed 3 years ago by asmirnov

Ads is visible even with ABP Chrome (desktop + mobile useragent)

Changed 3 years ago by asmirnov

Blocked with user-defined rule

comment:6 Changed 3 years ago by asmirnov

We can prevent loading ads with the following rule:

||m.baidu.com/rec?platform=wise&ms=1&rset=ad$xmlhttprequest

See attached screenshot with prevented loading ad.

comment:7 Changed 3 years ago by asmirnov

BTW, useragent to reproduce is "Mozilla/5.0 (Linux; Android 5.0; SM-N9005 Build/LRX21V; wv) AppleWebKit/537.36 (KHTML, like Gecko) Version/4.0 Chrome/54.0.2840.68 Mobile Safari/537.36"

comment:8 Changed 3 years ago by scheer

  • Tester changed from Unknown to Scheer
  • Verified working set
  • This no longer occurs in baidu.com with the steps detailed above.

Galaxy S5
Android 5.0.1
AdblockWebView (97)

comment:9 Changed 3 years ago by asmirnov

  • Resolution set to fixed
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.