Opened 3 years ago

Closed 3 years ago

#4650 closed defect (duplicate)

build.py script failing

Reported by: pavelz Assignee:
Priority: Unknown Milestone:
Module: Adblock-Plus-for-iOS/macOS Keywords:
Cc: fhd, mario Blocked By:
Blocking: Platform: iOS
Ready: yes Confidential: no
Tester: Unknown Verified working: no
Review URL(s):

https://github.com/adblockplus/adblockplussafariios/pull/33

Description

Environment

OSX build box

How to reproduce

  1. run build.py

Observed behaviour

Build fails on missing libpods and consequently also missing eligible signing assets

Expected behaviour

Build is successful and signed

Change History (6)

comment:1 Changed 3 years ago by pavelz

Two issues:

  1. Pods were built separately in build_dependencies step, and that just for the Extension target. Now the app needs the Pods (specifically yajl lib) in Host App target too. xcodebuild can't invoke two separate targets at one run so it would have to be invoked twice. Furthermore the separate invocation is generally redundant, because the invocation of umbrella app build builds Pods for all necessary targets anyway. It was just checking and skipping that step when it was built beforehand.
  1. The script was used last in January 2016, the provisioning profiles expired meanwhile. More specifically, the enterprise distribution cert (that the profiles were linking to) expired. I have relinked the existing provisioning profiles to a new cert expiring at 30 November 2018. This created new UUIDs for the profiles. The new profiles still need to be redownloaded from Apple Dev Center and reinstalled on the OSX build box.

comment:3 Changed 3 years ago by pavelz

  • Cc fhd added

comment:4 Changed 3 years ago by mario

  • Cc mario added

comment:5 Changed 3 years ago by mario

  • Ready set
  • Review URL(s) modified (diff)

comment:6 Changed 3 years ago by pavelz

  • Resolution set to duplicate
  • Status changed from new to closed

Obsoleted by #4905

Note: See TracTickets for help on using tickets.