Opened 21 months ago

Closed 21 months ago

Last modified 21 months ago

#4683 closed defect (fixed)

URL Fixer breaks location bar input when disabled

Reported by: trev Assignee: trev
Priority: P4 Milestone: URL-Fixer-next
Module: URL-Fixer Keywords:
Cc: greiner Blocked By:
Blocking: Platform: Unknown / Cross platform
Ready: yes Confidential: no
Tester: Unknown Verified working: no
Review URL(s):

https://codereview.adblockplus.org/29366656/

Description

Environment

URL Fixer 4.1.2.324
Firefox 53.0a1 nightly (older version might be affected as well)

How to reproduce

  1. Make sure URL Fixer extension is enabled.
  2. Disable URL Fixer extension.
  3. Type example.com into the location bar and press Enter.

Observed behaviour

Nothing happens, location bar won't accept input any more.

Expected behaviour

Location bar should still work.

Background

URL Fixer cannot restore urlbar.handleCommand property because that property is defined on the object prototype.

Change History (4)

comment:1 Changed 21 months ago by trev

  • Review URL(s) modified (diff)
  • Status changed from new to reviewing

comment:2 Changed 21 months ago by abpbot

A commit referencing this issue has landed:
Issue 4683 - URL Fixer breaks location bar input when disabled

comment:3 Changed 21 months ago by trev

  • Milestone set to URL-Fixer-next
  • Resolution set to fixed
  • Status changed from reviewing to closed

comment:4 Changed 21 months ago by trev

  • Priority changed from Unknown to P4
  • Ready set
Note: See TracTickets for help on using tickets.