Opened 3 years ago

Closed 3 years ago

#4709 closed defect (invalid)

Popups does not get closed on some pages in Adblock Plus for Firefox

Reported by: SMed79 Assignee:
Priority: Unknown Milestone:
Module: Adblock-Plus-for-Firefox Keywords:
Cc: trev, mapx Blocked By:
Blocking: Platform: Firefox
Ready: no Confidential: no
Tester: Unknown Verified working: no
Review URL(s):

Description (last modified by mapx)

Environment

Firefox 50.x
ABP 2.8.2
EasyList

How to reproduce

  1. Add the filter $popup
  2. Go to puissance2.fr
  3. Click the big blue button > Télécharger

Observed behaviour

Popup opened in new tab to getfile136.com

Expected behaviour

The popup must be blocked / closed.

Note

Chrome closed correctly & quickly the popup.

Change History (3)

comment:1 Changed 3 years ago by mapx

  • Cc trev mapx added
  • Component changed from Unknown to Adblock-Plus-for-Firefox
  • Description modified (diff)

comment:2 Changed 3 years ago by SMed79

According to gorhill and the documentation it's seem to be a legitimate popup.

[gorhill] wrote:

Because Firefox supports the isTrusted property [1], which is used to know if the popup is legitimate or not. In this case, the popup is legitimate because the URL of the big blue button is the same as the URL of the popup, so there are no surprises: the URL of the popup is the same as the URL of the clicked link.

The browsers based on Chromium did not support this property. I'm looking at the documentation on MDN [1], and apparently the isTrusted property is now supported since Chromium 46. I'd have to revise the code.

[1] https://developer.mozilla.org/en/docs/Web/API/Event/isTrusted

comment:3 Changed 3 years ago by mapx

  • Resolution set to invalid
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.