Opened 10 months ago

Closed 10 months ago

Last modified 6 months ago

#4714 closed defect (fixed)

"Block element" context menu item fails to open window

Reported by: trev Assignee: trev
Priority: P3 Milestone: Adblock-Plus-1.13-for-Chrome-Opera
Module: Platform Keywords:
Cc: kzar, sebastian Blocked By:
Blocking: Platform: Firefox
Ready: yes Confidential: no
Tester: Ross Verified working: yes
Review URL(s):

https://codereview.adblockplus.org/29366990/

Description

Environment

Firefox 53.0a1 nightly
Adblock Plus 1.12.4.1695 WebExt development build

How to reproduce

  1. Go to heise.de
  2. Right-click one of the images and choose "Block element"

Observed behaviour

No composer window opens, error message "Error: Type error for parameter createData (Property "focused" is unsupported by Firefox) for windows.create." shows up in Browser Console.

Expected behaviour

The composer window should open successfully.

Background

Firefox currently won't allow creating unfocused windows (bug 1253129), and it will error out if focused property is present - regardless of the value. However, we want to open a focused window and that's the default behavior in both Firefox and Chrome even though the documentation doesn't really make it clear (for Chrome the unit tests clearly show what the expected behavior is).

What to change

Omit focused parameter when creating windows since the window being focused is the default anyway.

Change History (6)

comment:1 Changed 10 months ago by trev

  • Review URL(s) modified (diff)
  • Status changed from new to reviewing

comment:2 Changed 10 months ago by kzar

  • Priority changed from Unknown to P3
  • Ready set

comment:3 Changed 10 months ago by abpbot

comment:4 Changed 10 months ago by trev

  • Milestone set to Adblock-Plus-for-Firefox-next
  • Resolution set to fixed
  • Status changed from reviewing to closed

comment:5 Changed 10 months ago by trev

  • Milestone changed from Adblock-Plus-for-Firefox-next to Adblock-Plus-for-Chrome-Opera-next

comment:6 Changed 6 months ago by Ross

  • Tester changed from Unknown to Ross
  • Verified working set

Fixed and working as expected in FF WebEx too.

ABP 1.12.4.1741
Firefox 52 / Windows 10
Firefox Nightly (53) / Windows 10

ABP 1.12.4.1739
Chrome 49 / 56 / Windows 10
Chrome 56 / OS X 10.12
Chrome 56 / Ubuntu 16.04
Opera 37 / 41 / Windows 7
Safari 10 / OS X 10.12

Note: See TracTickets for help on using tickets.