Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#4722 closed change (fixed)

Increase minimum Chrome version to 49 from 41

Reported by: kzar Assignee: kzar
Priority: P2 Milestone: Adblock-Plus-1.13-for-Chrome-Opera
Module: Platform Keywords:
Cc: sebastian, trev, wspee Blocked By:
Blocking: #4795 Platform: Chrome
Ready: yes Confidential: no
Tester: Ross Verified working: yes
Review URL(s):

https://codereview.adblockplus.org/29367316/
https://codereview.adblockplus.org/29371739/

Description (last modified by kzar)

Background

As of #4552 we removed JS Hydra. Unfortunately that broke things since Chrome versions lower than 45 don't support arrow functions and versions lower than 49 don't support destructuring.

What to change

  • Increase the minimum Chrome version to 49.
  • Remove legacy code and workarounds that are no longer required.

Change History (13)

comment:1 Changed 3 years ago by kzar

  • Description modified (diff)
  • Summary changed from Increase minimum Chrome version to 45 from 41 to Increase minimum Chrome version to 49 from 41

comment:2 Changed 3 years ago by wspee

  • Cc wspee added

comment:3 Changed 3 years ago by kzar

  • Description modified (diff)
  • Priority changed from Unknown to P2
  • Ready set
  • Review URL(s) modified (diff)
  • Status changed from new to reviewing

comment:4 Changed 3 years ago by kzar

  • Description modified (diff)

comment:5 Changed 3 years ago by abpbot

A commit referencing this issue has landed:
Issue 4722 - Drop support for Chrome 41-48 and remove legacy code

comment:6 Changed 3 years ago by kzar

  • Milestone set to Adblock-Plus-for-Chrome-Opera-next
  • Resolution set to fixed
  • Status changed from reviewing to closed

comment:7 Changed 3 years ago by Ross

  • Tester changed from Unknown to Ross

Minimum version change done. Removal of legacy code does not seem to have caused any obvious issues or regressions in Chrome. However it might have in Opera (see #4787).

ABP 1.12.4.1704
Chrome 41/45/48/49/53 / Windows 7
Chrome 41/45/48/49/53 / Windows 10
Chrome 41/45/48/49/53 / OS X 10.10

comment:8 Changed 3 years ago by kzar

  • Blocking 4795 added

comment:9 Changed 3 years ago by kzar

  • Resolution fixed deleted
  • Review URL(s) modified (diff)
  • Status changed from closed to reopened

(Reopening since I noticed another bit of code that can now be removed.)

comment:10 Changed 3 years ago by kzar

  • Status changed from reopened to reviewing

comment:11 Changed 3 years ago by abpbot

A commit referencing this issue has landed:
Issue 4722 - Remove old check for Chrome notification API

comment:12 Changed 3 years ago by kzar

  • Resolution set to fixed
  • Status changed from reviewing to closed

comment:13 Changed 3 years ago by Ross

  • Verified working set

Done.

ABP 1.12.4.1739
Chrome 43 . 49 / 56 / Windows 10

Note: See TracTickets for help on using tickets.