Opened 17 months ago

Closed 4 months ago

Last modified 4 months ago

#4724 closed defect (rejected)

Popups does not get blocked in Adblock Plus for Firefox

Reported by: SMed79 Assignee:
Priority: Unknown Milestone:
Module: Platform Keywords:
Cc: mapx, kzar Blocked By:
Blocking: Platform: Unknown / Cross platform
Ready: no Confidential: no
Tester: Unknown Verified working: no
Review URL(s):

Description

Environment

Firefox 50.x
ABP 2.8.2
EasyList

How to reproduce

+ Add the filter $popup,third-party

1.

  • Go to 123-movies.biz/2225-deepwater-horizon-full-movie.html
  • Click the green fake player.
  • Observed behaviour : first party popup redirect to an adserver.

2.

  • Go to ay8ou8ohth.com/embed-xlzrt6vi0902.html or exashare.com/embed-7573elqcd2xs.html
  • Click the red or grey X button.
  • Observed behaviour : first party popup redirect to an adserver.

3.

  • Go to http://1kino.in/
  • Click anywhere
  • Observed behaviour : first party popup redirect to different websites (clear cookies to reproduce again)

Expected behaviour

The third party popups must be blocked.

Change History (10)

comment:1 Changed 17 months ago by mapx

  • Cc trev mapx kzar added

comment:2 follow-up: Changed 17 months ago by mapx

the first can be managed:
@@|https://4*.net/*.js|
||openload.co/*license
||openload.co/*script
||123-movies.biz/moviehd.html$popup

The third case is pretty weird, probably is about background redirects like here:
https://issues.adblockplus.org/ticket/2095

Last edited 17 months ago by mapx (previous) (diff)

comment:3 in reply to: ↑ 2 Changed 17 months ago by SMed79

Replying to mapx:

the first can be managed:

It's not about openload player but the "green fake player".
These first party popups that redirect to third party adservers using :

setTimeout(function() {
    window.location.href = 'http://...'; 
}, 0);

e.g
youwatch.org/embed-xlzrt6vi0902.html
redirect to
ay8ou8ohth.com/embed-xlzrt6vi0902.html
if you block popups for ay8ou8ohth.com they use new domain ...

Also i know in some cas the popup can be managed by adding some extra whitelist filters but not effective because they does not stop using new domain at each blocking. More that that these whitelists filters will be abused to display ads on other websites.

Replying to mapx:

probably is about background redirects like here: 2095

I get no background redirection only popups

Third case : http://pastebin.com/mmgFgeHk

http://i.imgur.com/JIjuxmB.png

For the first two cases ubo block these popups without adding any additional filters :

http://i.imgur.com/adwZe8u.png

http://i.imgur.com/TL8ghAo.png

comment:4 Changed 16 months ago by SMed79

meta data redirection also will not closed by ABP.

e.g

<meta http-equiv="refresh" content="0.1;url=http://...">

comment:5 Changed 4 months ago by fhd

  • Cc trev removed

comment:6 Changed 4 months ago by kzar

  • Component changed from Unknown to Platform
  • Platform changed from Firefox to Unknown / Cross platform

Can you also reproduce this with Adblock Plus for Chrome? Can you reproduce with Adblock Plus 3.0.2 for Firefox?

comment:7 Changed 4 months ago by mapx

Old issue, never fixed, only with legacy ABP. In ABP for chrome was working.

comment:8 Changed 4 months ago by kzar

  • Resolution set to rejected
  • Status changed from new to closed

Thanks, closing this then.

comment:9 Changed 4 months ago by SMed79

@mapx

  1. Create the 3 below HTML files

links.html

<a href="#" onclick="window.open('https://forums.lanik.us/'); window.open('./1.html');">forums.lanik.us</a> (1)
<br>
<a href="#" onclick="window.open('https://forums.lanik.us/'); window.open('./2.html');">forums.lanik.us</a> (2)

1.html

<meta http-equiv="refresh" content="0;url=https://adblockplus.org/">

2.html

<script>
setTimeout(function() {
    window.location.href = 'https://adblockplus.org/'; 
}, 0);
</script>
  1. Add the filter ||adblockplus.org^$popup
  2. Open the page links.html and click the link forums.lanik.us (1)/(2)
  3. Check if the window opened in the new tab is closed using ABP/uBo

Merci.

comment:10 Changed 4 months ago by SMed79

Sorry for the noise. It was an issue from my side (a corrupted FF profile).

Note: See TracTickets for help on using tickets.