Opened 3 years ago

Closed 3 years ago

#4727 closed defect (rejected)

Chrome 49 tabs crashing "Aw, Snap!" for some websites

Reported by: kzar Assignee: kzar
Priority: P2 Milestone:
Module: Platform Keywords:
Cc: sebastian, trev Blocked By:
Blocking: Platform: Chrome
Ready: yes Confidential: no
Tester: Unknown Verified working: no
Review URL(s):

Description

Environment

Chrome Version 49.0.2623.75 (64-bit)
Adblock Plus aa21d219fd28
Debian chroot

How to reproduce

  1. Install Adblock Plus
  2. Browse to https://reddit.com

Observed behaviour

Tab consistently crashes with the "Aw, Snap!" message.

Expected behaviour

Tab does not crash.

Notes

  • I've bisected the issue and it is apparently being caused by the Issue 4586 - Wrap contentWindow to prevent access to unwrapped APIs change.
  • I'm not sure if it's a problem with the specific copy of Chrome 49 / chroot setup I have.
  • I've yet to find any information in the developer tools which hints at what is going wrong.
  • Some websites will crash reliably, some won't ever crash. I'm guessing it's related to iframe / contentWindow API usage.

Change History (1)

comment:1 Changed 3 years ago by kzar

  • Resolution set to rejected
  • Status changed from new to closed

(This was a regressions caused by a change for #4586. I have reverted that change and reoponed that issue.)

Note: See TracTickets for help on using tickets.