Opened 3 years ago

Closed 2 years ago

#4765 closed change (fixed)

Change minimum compatible versions

Reported by: diegocarloslima Assignee: diegocarloslima
Priority: P3 Milestone: Adblock-Browser-for-Android-1.2.0
Module: Adblock-Browser-for-Android Keywords:
Cc: fhd Blocked By:
Blocking: Platform: Adblock Browser for Android
Ready: yes Confidential: no
Tester: Scheer Verified working: yes
Review URL(s):

https://codereview.adblockplus.org/29370606/

Description (last modified by diegocarloslima)

Background

Since we're using our own versioning in Adblock Browser, we need to change the minimum compatible version preference for the app and the platform. That way, our ABP extension, which has maxVersion of 1.0 for adblockbrowser, doesn't get disabled.

What to change

Change both preferences extensions.minCompatibleAppVersion and extensions.minCompatiblePlatformVersion to 1.0.

Hints for Testers

This can be tested together with #2520 . With compatibility check enabled, it means that it will check if the ABP plugin is compatible with the ABB MOZ_APP_ID, which is55aba3ac-94d3-41a8-9e25-5c21fe874539 (ABP defines the compatible IDs here) and with the ABB app version, which is 1.1.1 (ABP defines the compatible versions here. So basically this issue can be verified by the fact that the ABP plugin is working after re-enabling compatibility check.

Change History (10)

comment:1 Changed 3 years ago by diegocarloslima

  • Review URL(s) modified (diff)
  • Status changed from new to reviewing

comment:2 follow-up: Changed 3 years ago by fhd

Looks like a regression from #2520 to me - wasn't this tested?

comment:3 Changed 3 years ago by fhd

  • Cc fhd added

comment:4 in reply to: ↑ 2 Changed 3 years ago by diegocarloslima

Replying to fhd:

Looks like a regression from #2520 to me - wasn't this tested?

Yes, it's a regression. I underestimated #2520 since the changes were pretty straightforward, so I just performed an android build instead of a full build to test it. That way, I couldn't detect this issue beforehand

comment:5 Changed 3 years ago by fhd

:)

comment:6 Changed 3 years ago by abpbot

A commit referencing this issue has landed:
Issue 4765 - Change minimum compatible versions

comment:7 Changed 3 years ago by diegocarloslima

  • Resolution set to fixed
  • Status changed from reviewing to closed

comment:8 Changed 2 years ago by scheer

  • Resolution fixed deleted
  • Status changed from closed to reopened
  • Tester changed from Unknown to Scheer

Is there any way for me to effectively check this? Is it possible for some hints for testers?

comment:9 Changed 2 years ago by diegocarloslima

  • Description modified (diff)

comment:10 Changed 2 years ago by scheer

  • Resolution set to fixed
  • Status changed from reopened to closed
  • Verified working set
  • The ABP plugin works after re-enabling the compatibility check.

adblockbrowser-1.1.1.20170612182010-arm
Galaxy S7
Android 7.0

Note: See TracTickets for help on using tickets.