Opened 6 months ago

Closed 5 weeks ago

Last modified 5 weeks ago

#4769 closed change (fixed)

Supporting adding whitelisted websites on ABP for Samsung Internet

Reported by: vickyyu Assignee:
Priority: Unknown Milestone: Adblock-Plus-for-Samsung-Browser-1.1.0
Module: Adblock-Plus-for-Samsung-Browser Keywords:
Cc: diegocarloslima Blocked By:
Blocking: Platform: Samsung Browser
Ready: yes Confidential: no
Tester: Scheer Verified working: yes
Review URL(s):

https://codereview.adblockplus.org/29376835/

Description (last modified by mario)

Background

Currently users cannot add their own whitelist websites on ABP for Samsung Internet. Thus we want to enable features to whitelist websites manually.

What to change

UI -- Settings overview

  • Add a new settings item called "Whitelisted websites" to the settings overview.

UI -- Whitelisted websites

  • Add a new settings screen called Whitelisted websites as shown in this screenshot.
  • Add a new dialog called Whitelist websites as shown in this screenshot

Logic -- Whitelisted websites

  • If the Whitelisted websites menu item is tapped, open the Whitelisted websites settings screen as shown above.
  • If no website is whitelisted the Whitelisted websites settings screen is empty.
  • If one or more websites are whitelisted the Whitelisted websites settings screen lists the whitelisted websites.
  • If Add a website to the whitelist is tapped, the Whitelist website modal dialog is shown.
    • if an invalid URL* is entered in the Whitelist website modal dialog or if the URL field is empty, disable the OK button as shown in this screenshot.
    • if a valid URL is entered in the Whitelist website modal dialog, enable the OK button.
    • If the CANCEL button is tapped, close the modal dialog and perform no action.
    • If the OK button is tapped, verify the URL, close the modal dialog and add the entered website to the list of whitelisted websites as shown in this screenshot.
    • If a website is whitelisted, no ads are blocked on this website.

*Invalid URL: invalid as per Patterns.WEB_URL.matcher and RFC 3987. URL's aren't tested for existence. TLD's aren't tested for validity.

Attachments (3)

ABP_SBrowser_Whitelist_00.png (40.0 KB) - added by mario 6 weeks ago.
ABP_SBrowser_Whitelist_01.png (47.9 KB) - added by mario 6 weeks ago.
ABP_SBrowser_Whitelist_02.png (124.0 KB) - added by mario 6 weeks ago.

Download all attachments as: .zip

Change History (13)

comment:1 Changed 5 months ago by diegocarloslima

  • Milestone set to Adblock-Plus-for-Samsung-Browser-next

comment:2 Changed 4 months ago by diegocarloslima

  • Review URL(s) modified (diff)
  • Status changed from new to reviewing
  • Summary changed from Supporting adding whitelisted websites on ABP for Samsung Interet to Supporting adding whitelisted websites on ABP for Samsung Internet

comment:4 Changed 2 months ago by diegocarloslima

  • Ready set
  • Resolution set to fixed
  • Status changed from reviewing to closed

Changed 6 weeks ago by mario

Changed 6 weeks ago by mario

Changed 6 weeks ago by mario

comment:5 Changed 6 weeks ago by mario

  • Description modified (diff)

Updated the description to reflect the way this feature was implemented for testers to perform proper QA.

comment:6 Changed 6 weeks ago by scheer

  • Tester changed from Unknown to Scheer
  • Verified working set

UI -- Settings overview

  • "Whitelisted websites" now appears in the settings overview.

UI -- Whitelisted websites

  • A new settings screen called Whitelisted websites is now shown.
  • A new dialog called Whitelist websites is now shown

Logic -- Whitelisted websites

  • When the Whitelisted websites menu item is tapped, the Whitelisted websites settings screen is opened.
  • When no website is whitelisted the Whitelisted websites settings screen is empty.
  • When one or more websites are whitelisted the Whitelisted websites settings screen listed the whitelisted websites.
  • When the Add a website to the whitelist is tapped, the Whitelist website modal dialog was shown.
    • When an invalid URL was entered in the Whitelist website modal dialog and when the URL field was empty, the OK button was disabled.
    • When a valid URL was entered in the Whitelist website modal dialog, the OK button was enabled.
    • When the CANCEL button was tapped, the modal dialog was closed.
    • When the OK button was tapped, the modal dialog was closed and the entered website was added to the list of whitelisted websites.
    • When the website was whitelisted, no ads were blocked on the website.

adblockplussbrowser-release-signed-1
Galaxy S7
Android 7.0

adblockplussbrowser-release-signed-1
Galaxy S4
Android 5.0.1

comment:7 Changed 6 weeks ago by traynard

A/C : "When an invalid URL was entered in the Whitelist website modal dialog and when the URL field was empty, the OK button was disabled."

Current Behavior: When entering in URLs such as "http://www.fa", "www.facebook", "www.face" and any other variation, the OK button gets enabled and allows userss to enter the partial URL to their whitelist.

comment:8 Changed 6 weeks ago by scheer

  • Resolution fixed deleted
  • Status changed from closed to reopened
  • Verified working unset

Re-opening as per traynards comment.

comment:9 Changed 5 weeks ago by mario

  • Description modified (diff)
  • Resolution set to fixed
  • Status changed from reopened to closed

As discussed, I've declared the method of URL verification in more detail in this ticket and added a follow up to handle better URL verification separately: #5254. Thus closing this issue.

comment:10 Changed 5 weeks ago by scheer

  • Verified working set
  • Now that the scope has been corrected with issue #5254, the above-mentioned feature works as intended.

adblockplussbrowser-release-signed-3
Galaxy S7
Android 7.0

adblockplussbrowser-release-signed-3
Galaxy S4
Android 5.0.1

Note: See TracTickets for help on using tickets.