Opened 3 years ago

Closed 3 years ago

Last modified 2 years ago

#4774 closed defect (fixed)

'Block ads on this page' does not remove whitelisting when re-selected

Reported by: scheer Assignee:
Priority: P3 Milestone: Adblock-Browser-for-Android-1.2.0
Module: Adblock-Browser-for-Android Keywords:
Cc: diegocarloslima Blocked By:
Blocking: Platform: Adblock Browser for Android
Ready: no Confidential: no
Tester: Scheer Verified working: yes
Review URL(s):

Description

When the user unchecks the 'Block ads on this site' to disable ABP, the box is not unchecked, but the page is reloaded and ads are shown. The one issue here is that the box is not unchecked, but in addition to this, if the user then selects the 'Block ads on this site' option again, the page still shows all ads.

Looking into the Settings > Ad blocking > More blocking options section, there seems to be a Whitelist created when they first select the 'Block ads on this site' that is never un-checked when re-selecting the option again thereafter.

Environment

ABB Android Test 1.1.1
Android 6.0.1
Galaxy S7

How to reproduce

  1. Visit http://www.msn.com
  2. Select the settings burger
  3. Select 'Block ads on this site'
  4. Select the settings burger
  5. Select 'Block ads on this site'

Observed behaviour

The first selection whitelists the site, but the second selection does not remove the whitelist and ads are still shown.

Expected behaviour

The second selection should re-enable ABP and remove the whitelist.

Change History (3)

comment:2 Changed 3 years ago by diegocarloslima

  • Milestone set to Adblock-Browser-for-Android-next
  • Priority changed from Unknown to P3
  • Resolution set to fixed
  • Status changed from new to closed

comment:3 Changed 2 years ago by scheer

  • Tester changed from Unknown to Scheer
  • Verified working set
  • The re-selection of the option 'Block ads on this page' correctly reloads the page and removes the whitelist to block all ads again.

ABB adblockbrowser-1.1.1.20170612182010-arm
Galaxy S7
Android 7.0

Note: See TracTickets for help on using tickets.