Opened 6 years ago

Closed 6 years ago

#480 closed defect (duplicate)

AdBlock Plus 1.8 momentarily and regularly freezes Chrome

Reported by: selulven Assignee:
Priority: Unknown Milestone:
Module: Platform Keywords:
Cc: smultron45@… Blocked By:
Blocking: Platform:
Ready: no Confidential: no
Tester: Verified working: no
Review URL(s):

        

Description (last modified by sebastian)

Environment

Windows 7 Pro 64 bit
Chrome 34.0.1847.131 m
ABP 1.8.1

Filters:

*.samsung.se/adserver/*
*jobbdirekte*
*srvkrswcf01*
@@llnwd.net/*.css|
@@|http://crev.vo.llnwd.net/o42/rbrforums/styles/forums-style.css
@@|http://www.facebook.com/pages/Team-Jens/206636999380364?$document
@@|http://www.facebook.com/thequikdraw/posts/514859538573964|$document
@@||pji.nu/css^
@@||pji.nu/js^
@@||tadst.com^
cache.finn.no/clientscript/finn/bap/moreLikeThis.js|
||addthis.com^
||adexprt.com^
||adform.net^
||ads.revsci.net^
||ads.terrengsykkel.no^
||ads^
||adtech.de^
||adviva.net^
||affiliatelounge.com^
||annonser.dagbladet.no^
||atdmt.com^
||atemda.com^
||bannerflow.com^
||burt.io^
||cdn.streameye.net/upload/*
||cdn4.emediate.eu^
||chartbeat.com^
||chartbeat.net^
||clicktale.net^
||clkads.com^
||criteo.net^
||dn.no/www.dn.no/include/swf/*
||doubleclick.net^
||edgecastcdn.net^
||essens.no^
||facebook.com^
||facebook.net^
||finncdn.no/trafikk/*
||flash.vg.no^
||fusion.nettavisen.no^
||google-analytics.com^
||googlesyndication.com^
||googletagservices.com^
||helios.finn.no^
||letsdealno-apiimages.s3.amazonaws.com^
||llnwd.net^
||lp4.io^
||mediadakine.com^
||mediaplex.com^
||mixpanel.com^
||multimedia.aftenbladet.no/marked/*
||optimizely.com^
||pji.nu^
||plusone.google.com^
||revsci.net^
||richmetrics.com^
||sascdn.com^
||sasecondary.medianorge.no^
||scorecardresearch.com^
||serving-sys.com^
||specificclick.net^
||srvkrswcf01^
||statcamp.net^
||tadst.com^
||tns-cs.net^
||trafikkfondet.no^
||tribalfusion.com^
||vindicosuite.com^
||webhit.snd.no^
||www.terrengsykkel.no###ad*
||xiti.com^
||yieldmanager.com^

How to reproduce

Enable AdBlock Plus
Notice how at regular intervals (~once per minute), Chrome will freeze completely for a number of seconds (~10)
Disable AdBlock Plus
Notice how freezing went away

Observed behaviour

Chrome becomes completely unresponsive (no graphical updates, does not respond to window events).
Sound from videos keeps playing even if the image has stopped.

Expected behaviour

Chrome remains completely responsive.

Attachments (1)

filters.txt (1.6 KB) - added by selulven 6 years ago.
AdBlock filters

Download all attachments as: .zip

Change History (25)

comment:1 Changed 6 years ago by mapx

what filters are those ? custom filters ?
and ...

@@@@@@

is a filter ?

where does it happen ? all the sites ? if no, provide the page / link

Are some filter lists enabled ? (easylist for example)

What if you use only easylist ? (removing your custom filters)

comment:2 Changed 6 years ago by mapx

  • Cc smultron45@… added

Changed 6 years ago by selulven

AdBlock filters

comment:3 Changed 6 years ago by selulven

The filters are mangled by trac -- they don't look like that in AdBlock. I've attached a file with the filters instead.

It happens on all sites.
There are no filter lists enabled.

I'll try EasyList and see what happens.

comment:4 Changed 6 years ago by selulven

Happens with EasyList as well.

comment:5 Changed 6 years ago by mapx

only with easylist ? did you remove your custom filters ?

comment:6 Changed 6 years ago by mapx

  • Review URL(s) modified (diff)

even using only your filters I can not reproduce the "issue".

Could be some conflict with other extension, or a conflict with your security software

Last edited 6 years ago by mapx (previous) (diff)

comment:7 Changed 6 years ago by selulven

Happens with only EasyList -- I removed my custom filters completely.

The "issue", as you so aptly phrased it, started about a week ago, and I haven't changed my filters for months. The only apparent change from about a week ago was a new AdBlock Plus.

comment:8 Changed 6 years ago by mapx

you could try to "install" a chrome portable (try the beta 35 for example)
http://portableapps.com/apps/internet/google_chrome_portable

and re-test

or create a new profile in your chrome
https://support.google.com/chrome/answer/142059?hl=en

comment:10 Changed 6 years ago by philll

How is your RAM usage? Still left an appropriate amount when ABP is running?

comment:11 Changed 6 years ago by mapx

if you remove

www.terrengsykkel.no###ad*

does the freezing still happen ?

comment:12 Changed 6 years ago by selulven

The freezing stopped after I removed that filter. I've added the filter again to see if the freezing re-appears. I'll keep you posted.

Regarding RAM usage, there is no amount of memory consumed by any application on my machine I would deem "appropriate". Chrome uses several gigabytes in my regular browsing session.

comment:13 follow-up: Changed 6 years ago by joelg

I'm also having this problem, on multiple systems - 2 Windows 7 x64 (latest Chrome Canary), and one Fedora 20 (latest Chrome stable).

During browsing tabs will just spin and not open pages. If I disable Adblock, the pages finish opening immediately. I've also gotten errors that Adblock has crashed (only on the Fedora box).

Joel

comment:14 in reply to: ↑ 13 Changed 6 years ago by mapx

Replying to joelg:

I'm also having this problem, on multiple systems - 2 Windows 7 x64 (latest Chrome Canary), and one Fedora 20 (latest Chrome stable).

During browsing tabs will just spin and not open pages. If I disable Adblock, the pages finish opening immediately. I've also gotten errors that Adblock has crashed (only on the Fedora box).

Joel

open your own issue with all the details (abp version, filter lists, example links, chrome version, steps to reproduce the issue)

if you are using custom filters try removing all of them and re-test

comment:15 Changed 6 years ago by mapx

  • Resolution set to fixed
  • Status changed from new to closed

as for the original issue, removing that filter the freezing is gone

comment:16 Changed 6 years ago by selulven

  • Resolution fixed deleted
  • Status changed from closed to reopened

I'm still testing to see if removing/adding the filter affects the freezing behaviour.

Also, why close the ticket if that particular filter is the issue? Is it an illegal filter specification?

comment:18 Changed 6 years ago by mapx

you could try

terrengsykkel.no##div[id*="ad"]
Last edited 6 years ago by mapx (previous) (diff)

comment:19 Changed 6 years ago by selulven

After the freezing became too annoying to have ABP enabled, I installed FlashBlock to least get rid some of the more annoying animated ads.

The freezing does not re-occur if I have enabled FlashBlock. I.e. when no flash files are loaded, even with the filter above in place, the freezing does not happen.

When I disable FlashBlock, the freezing starts happening again.

I.e. it seems when flash files are loaded AND the above filter is in place, the freezing happens. Otherwise not.

comment:20 Changed 6 years ago by mapx

Did you try the filter I wrote above ? or the wrong one ?

comment:21 Changed 6 years ago by selulven

Sorry about the ambiguity. When I said "the above filter", I was referring to the incorrect one that we suspect causes the freezing, not your suggested new filter.

comment:22 Changed 6 years ago by mapx

well, I don't understand why are you testing that one, remove it, it's wrong ! end of the story

comment:23 Changed 6 years ago by selulven

Because I'm curious.

The wrong filter does not cause freezing when Flash is blocked. Doesn't that make you wonder why the behaviour is different? Could there be a bug somewhere after all, related to Flash, even if the filter is also wrong? It's your decision to act on it or not.

Thank you for identifying the incorrect syntax, though. I can't remember if it was produced by the Firefox version of ABP or some extension to it, or if I wrote it myself off of a template I found.

I'll give your modified version a try and see if it does what I intended for the incorrect one to do.

comment:24 Changed 6 years ago by sebastian

  • Component changed from Unknown to Platform
  • Description modified (diff)
  • Resolution set to duplicate
  • Status changed from reopened to closed

If an invalid CSS selector makes Chrome crash, this is a bug in Chrome. But we should prevent users from adding invalid filters. However there is already #491 for adding validation for custom filters.

Note: See TracTickets for help on using tickets.