Opened 6 years ago

Closed 5 years ago

#481 closed defect (incomplete)

ABP Chrome version 1.8.1 doesn't work on Liebao browser

Reported by: vickyyu Assignee:
Priority: P2 Milestone:
Module: Unknown Keywords:
Cc: smultron45@…, manvel@… Blocked By:
Blocking: Platform: Chrome
Ready: yes Confidential: no
Tester: Verified working: no
Review URL(s):

Description

Environment

Liebao browser (version 4.6.50.7737) User Agent String is:
Mozilla/5.0 (Windows NT 6.3; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/29.0.1547.66 Safari/537.36 LBBROWSER
ABP 1.8.1 for Chrome

How to reproduce

  1. Start Liebao browser(version 4.6.50.7737)
  2. Open adblockplus.org page in Liebao browser
  3. Add the chrome version to the browser
  4. Go to any page to test and all ads are not blocked.

Observed behaviour

  1. There is a notification saying that ABP is successfully added to Liebao browser.
  2. Click ABP icon, the number of blocked ads remains 0.
  3. Click again ABP icon, the "settings" under ABP icon can't be clicked.
  4. The only possibility to enter the setting page is to right click ABP icon, and choose "settings".
  5. There is no filter list selected.
  6. Select and add Easylist China to it.
  7. Go to any Chinese test page (e.g. www.163.com), all the ads no still not blocked.

Expected behaviour

Since ABP version 1.7.4 works well on Liebao browser, it is expected to work well with the latest version.

Change History (8)

comment:1 Changed 6 years ago by mapx

if Liebao browser is a chromium browser, which is the chromium version used for version 4.6.50.7737 ?

comment:2 Changed 6 years ago by mapx

  • Cc smultron45@… added

comment:3 Changed 6 years ago by philll

  • Priority changed from Unknown to P2

Liebao has round about 12 million users according to vickys translation of some chinese websites. The current ABP version in their web store is still 1.7.4

comment:4 Changed 5 years ago by saroyanm

  • Platform set to Unknown

Installed liebao Version 4.7.54.8189 ( Chrome/29.0.1547 ),
When I'm trying to install ABP from adblockplus.org, always redirected to Chrome Web store and getting message that Chrome Web Store does not support the version you are using.
Download the latest version of Google Chrome.
Seams like Chrome Web Store not allow to use old browser to download extensions, will try to check exact versions of chrome, which no more supported.

Last edited 5 years ago by saroyanm (previous) (diff)

comment:5 Changed 5 years ago by saroyanm

According to comment in this issue:
https://code.google.com/p/chromium/issues/detail?id=377278#c16

Google now blocking installs for Chrome versions under "31.0.1608.2" and urge user to upgrade.

Last edited 5 years ago by saroyanm (previous) (diff)

comment:6 Changed 5 years ago by saroyanm

  • Cc manvel@… added

comment:7 Changed 5 years ago by trev

  • Platform changed from Unknown to Chrome

comment:8 Changed 5 years ago by sebastian

  • Resolution set to invalid
  • Status changed from new to closed

So Google fixed that issue for us by preventing users from installing Adblock Plus on Liebao.

Note: See TracTickets for help on using tickets.