Opened 3 years ago

Closed 3 years ago

#4831 closed defect (worksforme)

Running build.py with devenv flag throws an error

Reported by: saroyanm Assignee:
Priority: Unknown Milestone:
Module: Unknown Keywords:
Cc: sebastian, greiner Blocked By:
Blocking: Platform: Unknown / Cross platform
Ready: no Confidential: no
Tester: Unknown Verified working: no
Review URL(s):

Description (last modified by saroyanm)

Environment

Ubuntu 14.04
Python 2.7.6

How to reproduce

  1. Clone adblockpluschrome repository
  2. Run in terminal python build.py -t chrome devenv
  3. observe

Observed behaviour

An error message in the output:

INFO: Updating repository /home/saroyanm/projects/abp/adblockplusui/adblockpluschrome/buildtools to revision 4cea55c4bdc0
INFO: Updating repository /home/saroyanm/projects/abp/adblockplusui/adblockpluschrome/adblockplus to revision c8ec667756d3
INFO: Updating repository /home/saroyanm/projects/abp/adblockplusui/adblockpluschrome/adblockplus/buildtools to revision dadad687f607
INFO: Updating repository /home/saroyanm/projects/abp/adblockplusui/adblockpluschrome/adblockplus/buildtools/jshydra to revision 46a20922f3db
INFO: Updating repository /home/saroyanm/projects/abp/adblockplusui/adblockpluschrome/adblockplus/adblockpluscore to revision b1e70036624f
INFO: Updating repository /home/saroyanm/projects/abp/adblockplusui/adblockpluschrome/adblockplus/adblockplusui to revision 4286b54830e5
INFO: Updating repository /home/saroyanm/projects/abp/adblockplusui/adblockpluschrome/adblockpluscore to revision b1e70036624f
INFO: Updating repository /home/saroyanm/projects/abp/adblockplusui/adblockpluschrome/adblockplusui to revision 575d910d9d2e
Traceback (most recent call last):
  File "build.py", line 18, in <module>
    buildtools.build.processArgs(BASE_DIR, sys.argv)
  File "/home/saroyanm/projects/abp/adblockplusui/adblockpluschrome/buildtools/build.py", line 601, in processArgs
    commands[command](baseDir, scriptName, opts, args, type)
  File "/home/saroyanm/projects/abp/adblockplusui/adblockpluschrome/buildtools/build.py", line 55, in __call__
    return self._handler(baseDir, scriptName, opts, args, type)
  File "/home/saroyanm/projects/abp/adblockplusui/adblockpluschrome/buildtools/build.py", line 235, in createDevEnv
    packager.createBuild(baseDir, type=type, outFile=file, devenv=True, releaseBuild=True)
  File "/home/saroyanm/projects/abp/adblockplusui/adblockpluschrome/buildtools/packagerChrome.py", line 378, in createBuild
    convertJS(params, files)
  File "/home/saroyanm/projects/abp/adblockplusui/adblockpluschrome/buildtools/packagerChrome.py", line 186, in convertJS
    modules=modules
  File "/usr/local/lib/python2.7/dist-packages/Jinja2-2.7.3-py2.7.egg/jinja2/environment.py", line 969, in render
    return self.environment.handle_exception(exc_info, True)
  File "/usr/local/lib/python2.7/dist-packages/Jinja2-2.7.3-py2.7.egg/jinja2/environment.py", line 742, in handle_exception
    reraise(exc_type, exc_value, tb)
  File "/home/saroyanm/projects/abp/adblockplusui/adblockpluschrome/buildtools/templates/modules.js.tmpl", line 10, in top-level template code
    {%- set modules = dict(modules) -%}
TypeError: <lambda>() takes exactly 0 arguments (1 given)

Expected behaviour

No error message and successful project build in devenv.chrome folder

Change History (3)

comment:1 Changed 3 years ago by saroyanm

As a side note this error is being caused on my side after current changeset.

comment:2 Changed 3 years ago by saroyanm

  • Description modified (diff)

Added Python version as well

comment:3 Changed 3 years ago by saroyanm

  • Resolution set to worksforme
  • Status changed from new to closed

The problem was because I didn't have the required version of PIL and Jinja2, now works for me sorry for the stress.

Note: See TracTickets for help on using tickets.